Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Not able to install 16.2.8 from gitlab runner. Error: rcedit.exe failed with exit code 1. wine: '/root/.wine' is a 32-bit installation

See original GitHub issue

Hey folks I’m not able to install castlabs electron version 16.2.8. Looks like it generates wrong download url, could you please point out how to specify the correct download URL?

here is error `> electron@16.2.8 postinstall /builds/all/pix/legacy/pix-app/p3/lumiere/node_modules/electron

node install.js HTTPError: Response code 404 (Not Found) for at EventEmitter.<anonymous> (/builds/all/pix/legacy/pix-app/p3/lumiere/node_modules/got/source/as-stream.js:35:24) at EventEmitter.emit (events.js:314:20)`

and here is package.json fragment

"electron": "",

Issue Analytics

  • State:closed
  • Created 10 months ago
  • Comments:5

github_iconTop GitHub Comments

demchuk-alexcommented, Nov 11, 2022

Ok issue solved, for those who are interested: Lastest versions of castlab electrons 16+ only installed properly with node 16 as mentioned in here

My last question is related to electron-packager usage in gitlab runner with electronuserland/builder:wine docker image, so fix could be found here in nutshell

# Removes the original 32-bit wine prefix from the generated image
rm -rf /root/.wine
# Creates a new 64-bit one

latter will reinitialize wine and successfully package electron app. Anyway @khwaaj Thanks a lot!

khwaajcommented, Nov 10, 2022

Looks like you got a 64-bit rcedit.exe and are trying to run it with 32-bit Wine? You probably need to update the Wine installation somehow, but this is not something I have a great deal of experience with. I recommend Googling it 🙂

Read more comments on GitHub >

github_iconTop Results From Across the Web

Cannot package for win32 with wine #1080 - electron/forge
Always fails at the rcedit.exe stage, depending on the WINEARCH setting: ... with exit code 1. wine: '/root/.wine' is a 32-bit installation, ...
Read more >
Issue With 32-bit Windows Runners - GitLab CI/CD
On the same machines, the jobs fail to load a (signed) driver. This typically happens when the application is run without sufficient privileges....
Read more >
rcedit.exe failed with exit code 193. wine: Bad EXE format
My solution is now this: FROM node:10 RUN dpkg --add-architecture i386 && apt-get update && apt-get install wine wine32 -y RUN npm install...
Read more >
X 32-bit development files - Install problems - WineHQ Forums
configure: error: X 32-bit development files not found. Wine will be built without X support, which probably isn't what you want.
Read more >
Wine not running this exe setup file in Void Linux
ShellExecuteEx failed: File not found. Same error comes if I use wine64 instead of wine. I found some links for this error (e.g....
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found