Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Update to 3.5.2 via pip exits with error

See original GitHub issue

When I try to upgrade srt via pip install -U srt from 3.5.1 to 3.5.2, pip breaks with error. Previous installations worked without problem.

Debian 10 Python 3.7.3 pip 22.0.3 setuptools 60.9.3

pip console output:

Collecting srt
  Downloading srt-3.5.2.tar.gz (24 kB)
  Preparing metadata ( ... error
  error: subprocess-exited-with-error
  × python egg_info did not run successfully.
  │ exit code: 1
  ╰─> [8 lines of output]
      /home/steffen/.local/lib/python3.7/site-packages/setuptools/_distutils/ UserWarning: Unknown distribution option: 'python_requires'
      usage: [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
         or: --help [cmd1 cmd2 ...]
         or: --help-commands
         or: cmd --help
      error: invalid command 'egg_info'
      [end of output]
  note: This error originates from a subprocess, and is likely not a problem with pip.
error: metadata-generation-failed

× Encountered error while generating package metadata.
╰─> See above for output.

note: This is an issue with the package mentioned above, not pip.
hint: See above for details.

Issue Analytics

  • State:closed
  • Created 2 years ago
  • Comments:7 (4 by maintainers)

github_iconTop GitHub Comments

SteffenBauercommented, Mar 16, 2022

Next update: I submitted an issue report to setuptools, turned out that everything works in a virtual environment or docker environment. After a lot of investigating, the reason was a corruption in my local python lib directory. Funny that this caused an issue only with the newest setuptools, but not with older ones. After removing the corruption artifact, and a clean reinstall of setuptools, srt can now be installed again smoothly and without problem.

SteffenBauercommented, Mar 16, 2022

Update on this: I got also the same problem upgrading other packages with pip. Downgrading setuptools to 60.8.2 solved the problem; upgrading pypi packages, including srt, then works. Browsing the setuptools repository on github shows that currently there are a lot of bug reports regarding handling of egg. So the problem quite definitely is not in the srt package, but something was broken in the newest setuptools.

Read more comments on GitHub >

github_iconTop Results From Across the Web

[BUG] Upgrading some packages via pip fails with error ...
[BUG] Upgrading some packages via pip fails with error message related to setuptools 60.9.3. Downgrading setuptools to 60.8.2 works. #3173.
Read more >
Pip broken after upgrade. Cannot unsinstall ... - Stack Overflow
1 You are using pip version 8.1.1, however version 22.1 is available. You should consider upgrading via the 'pip install --upgrade pip' command....
Read more >
setuptools 3.5.2 - PyPI
Easily download, build, install, upgrade, and uninstall Python packages.
Read more >
Installing scikit-learn
When using pip, please ensure that binary wheels are used, and NumPy and SciPy are not recompiled from source, which can happen when...
Read more >
ote: this error originates from a subprocess, and is likely not a ...
I fixed the problem by installing an older version of pip using the command: pip install pip==21.3.1. Open side panel. "note: This error...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found