Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Homebrew error sha1

See original GitHub issue


I have homebrew error each time i try to use it.

don’t kow if it’s related to panamax.

Error: Calling Formula.sha1 is disabled! Use Formula.sha256 instead. /Users/beatminer/Library/Caches/Homebrew/Formula/panamax.rb:7:in class:Panamax’ Please report this bug: /usr/local/Homebrew/Library/Homebrew/utils.rb:86:in odeprecated' /usr/local/Homebrew/Library/Homebrew/utils.rb:94:in odisabled’ /usr/local/Homebrew/Library/Homebrew/compat/sha1.rb:3:in sha1' /Users/beatminer/Library/Caches/Homebrew/Formula/panamax.rb:7:in class:Panamax’ /Users/beatminer/Library/Caches/Homebrew/Formula/panamax.rb:4:in load_formula' /usr/local/Homebrew/Library/Homebrew/formulary.rb:25:in module_eval’ /usr/local/Homebrew/Library/Homebrew/formulary.rb:25:in load_formula' /usr/local/Homebrew/Library/Homebrew/formulary.rb:42:in load_formula_from_path’ /usr/local/Homebrew/Library/Homebrew/formulary.rb:97:in load_file' /usr/local/Homebrew/Library/Homebrew/formulary.rb:88:in klass’ /usr/local/Homebrew/Library/Homebrew/formulary.rb:84:in get_formula' /usr/local/Homebrew/Library/Homebrew/formulary.rb:241:in factory’ /usr/local/Homebrew/Library/Homebrew/formulary.rb:269:in from_keg' /usr/local/Homebrew/Library/Homebrew/formulary.rb:255:in from_rack’ /usr/local/Homebrew/Library/Homebrew/formula.rb:1364:in block in installed' /usr/local/Homebrew/Library/Homebrew/formula.rb:1362:in map’ /usr/local/Homebrew/Library/Homebrew/formula.rb:1362:in installed' /usr/local/Homebrew/Library/Homebrew/cmd/upgrade.rb:37:in upgrade’ /usr/local/Homebrew/Library/Homebrew/brew.rb:94:in <main>'

Issue Analytics

  • State:open
  • Created 7 years ago
  • Comments:8

github_iconTop GitHub Comments

cleaner321commented, Dec 12, 2016

I only changed the sha1 to the new sha256 version …

  1. create a file called panamax.rb
  2. paste the code below
  3. serve it
  4. brew install http://LOCALHOST/panamax.rb && panamax init

require “formula”

class Panamax < Formula homepage “” url “” sha256 “b59f21e5a821a3886eab0e62f85fc89d8fedea6099b79d3447906dfc36d163d7” def install system “./configure”, “–prefix=#{prefix}”, “–var=#{var}/panamax” system “make”, “install” resource(“additional_files”).stage { bin.install “panamaxcli-darwin” } mv bin/“panamaxcli-darwin”,bin/“pmxcli” end

def caveats “If upgrading the Panamax Installer, be sure to run ‘panamax reinstall’ to ensure compatibility with other Panamax components.” end

resource “additional_files” do url “” sha256 “58bd24d40260e269105f21f58369a002b6ebb2d6877f7ac3ffa29e280ecc6007” end

test do assert File.exist?(“#{prefix}/.panamax”) assert File.exist?(“#{var}/panamax”) assert_match “#{version}”, shell_output(“#{prefix}/.panamax/panamax -v”).strip end end

bfontainecommented, Dec 12, 2016

@cleaner321 You don’t need to do such complicated things; just paste this code in a file and run brew install ./panamax.rb.

Read more comments on GitHub >

github_iconTop Results From Across the Web

SHA1 error when using brew install - Stack Overflow
Incase the brew update fails, try the following cd `brew --prefix` git remote add origin git fetch ...
Read more >
undefined method `sha1' for #<Class:0x007f95a520c348>
The error is in the tap larsimmisch/avr ( You need to remove that tap, which is using very old (and ...
Read more >
Homebrew: SHA1 Mismatch Even After Update - Ask Different
Solved it by moving to another network and trying to reinstall. Though I got the same error I knew the file was complete...
Read more >
MD5 and SHA-1 Deprecation - Homebrew Documentation
We removed SHA1 support in November 2016, 21 months after we started warning people to move away from it for verification. This is...
Read more >
Homebrew – force install even with SHA1 mismatch – iTecNote
I'm installing something through homebrew but one of it's dependencies is failing to install, saying that the downloaded artifact has a different SHA1...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found