Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Error with animated draco

See original GitHub issue


So today I played some time with the new draco feature. Everything seemed to work fine, expect for when I tried to compress animated gltfs:

Without draco: without_draco

With draco: with_draco

The validator on donmccurdy’s viewer says the following error: Length of 0x004e4942 chunk is not aligned to 4-byte boundaries

When I export it as a gltf+bin (instead glb), the error is not showing up, but the visual artifact is the same. As well, as in the babylon sandbox. When I remove the -d from the command, the exported file’s animation works well, so I’m pretty sure draco has something to do with it.

The command I use: node bin/gltf-pipeline.js -i input/cube.gltf -s -d -b -o output/cube.glb

My files:

Issue Analytics

  • State:closed
  • Created 5 years ago
  • Comments:5 (4 by maintainers)

github_iconTop GitHub Comments

FrankGalligancommented, May 1, 2018

So currently encoding a mesh with morph targets with default settings could cause errors as you observed. I’m going to make a change to gltf-pipeline to fix these types of files. The compression won’t be as good as I’m going to force sequential encoding which will preserve the order.

Later on, we will make changes to properly handle animation and morph targets.

soadzoorcommented, May 1, 2018

Great, thanks guys for the quick fix!

Read more comments on GitHub >

github_iconTop Results From Across the Web

Error with animated draco #365 - CesiumGS/gltf-pipeline
When I export it as a gltf+bin (instead glb ), the error is not showing up, but the visual artifact is the same....
Read more >
Loading 3D model with animation using ... - Stack Overflow
I'm trying to load this GBL file and play the animation. This code returns the following error: TypeError: Cannot read property 'length' of ......
Read more >
Load draco .glb model error - PlayCanvas Forum
I want to load glb models,when I run my code,it only some glb models been loaded successfully,and I got this error,but when I...
Read more >
Bones animation error with GLTF - Questions - three.js forum
Hi folks, I have some problem with a GLTF model exported with Blender 2.8. Bones don't animate correctly in the the online viewer, ......
Read more >
LVL IT UP || meme || Animation || FlipaClip || Error 2 - YouTube
"Han-Jae" animation /parallax (W.I.P for Tuxiiedos!) | *Read description please* ///BLOOD WARNING///. Draco Scurra. Draco Scurra.
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found