Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Request retry has failed due to NoSuchMethodError when trying to use any method

See original GitHub issue

Hi Thanks for your sdk! I am trying to make a simple call like this:

ShopifySdk shopifySdk = ShopifySdk.newBuilder() .withSubdomain("******") .withAccessToken("***********************************") .build(); final int shopifyCount = shopifySdk.getProductCount();

but i am getting a ShopifyClientException with message: “Request retry has failed” with a full stacktrace:

com.shopify.exceptions.ShopifyClientException: Request retry has failed. at com.shopify.ShopifySdk.invokeResponseCallable( at com.shopify.ShopifySdk.get( at com.shopify.ShopifySdk.getShop( at com.shopify.ShopifySdk.getWebTarget( at com.shopify.ShopifySdk.getProductCount( at com.mypackage.etc Caused by: java.util.concurrent.ExecutionException: java.lang.NoSuchMethodError:;[Ljava/lang/Object;)V at com.github.rholder.retry.Retryer$ExceptionAttempt.<init>( at at com.shopify.ShopifySdk.invokeResponseCallable( ... 6 more Caused by: java.lang.NoSuchMethodError:;[Ljava/lang/Object;)V at org.glassfish.jersey.client.ClientRequest.accept( at org.glassfish.jersey.client.JerseyWebTarget.request( at org.glassfish.jersey.client.JerseyWebTarget.request( at com.shopify.ShopifySdk.lambda$get$4( at com.github.rholder.retry.AttemptTimeLimiters$ at

I also tried other methods like getShop() etc but they give the same error, i also tried to modify retry limits delays etc but no luck. I also verified that my token is right. Any thoughts? Thanks in advance

Issue Analytics

  • State:closed
  • Created 4 years ago
  • Comments:5 (3 by maintainers)

github_iconTop GitHub Comments

ChrisMpitzioscommented, Sep 16, 2019

Thanks again for your response, the issue was indeed the versions of jersey and despite my effort to fix it without updating, i concluded that its ‘impossible’ (and if finally done, then its risky due to different implementations for many methods between the versions). We proceeded with updating to glassfish and playing around with your sdk, so consider the issue solved 😃 . In order not to open another issue i have a non related - but fast question : i noted that despite the fact that i create a product with withAvailable(randomStockValue) the product always appear as Sold Out, but when i then use updateInventory then it updates the quantity correctly. Does this have to do with Shopify’s flow (or some deprecation made from Shopify’s side) or am i just doing something wrong ?

ryankazokascommented, Sep 16, 2019

np @ChrisMpitzios . As far as updating inventory levels go, yes shopify started to deprecate the inventory quantities on the variant’s themselves in favor of inventory levels, so that they can achieve inventory levels across locations. The available quantity on those newer variants are just a roll up of quantities at all locations and is not a writable field anymore.

Details on that here.

I’m going to close this specific issue out. If you have any more questions regarding inventory, feel free to open another issue.

Read more comments on GitHub >

github_iconTop Results From Across the Web

3 Steps to Fix NoSuchMethodErrors and ...
Step 1: Find Out Where the Class Comes From ... First, we need to find out where the class containing the method in...
Read more >
Issue with io.github.resilience4j version 1.7.2 ... - Stack Overflow
Everything is working fine with 1.6.1 version but when upgraded to 1.7.1 version my application is not running. Please find my code changes ......
Read more >
How to Fix java.lang.NoSuchMethodError in Java - Rollbar
NoSuchMethodError is a runtime error in Java which occurs when a method is called that exists at compile-time, but does not exist at...
Read more >
NoSuchMethodError in ...
This error arose due to jar file incompatibility. I had hadoop-2.8.0 but hadoop-hdfs-client-2.8.0 and hadoop-hdfs-2.6.0 were trying to call the ...
Read more >
java lang NoSuchMethodError No such DSL method pipeline ...
Hi Guys,. I am trying to run one Job using Jenkins Pipeline. But It is showing me the below error. java.lang.NoSuchMethodError: No such...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found