Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

[BUG] ImportError when running latest version

See original GitHub issue

Describe the bug

Cellxgene crashes on startup.

To Reproduce Steps to reproduce the behavior:

  1. pip3 install cellxgene
  2. cellxgene launch

Expected behavior

Cellxgene should not crash.

Error log

$ cellxgene launch

Traceback (most recent call last):
  File "/usr/local/bin/cellxgene", line 5, in <module>
    from server.cli.cli import cli
  File "/usr/local/lib/python3.8/dist-packages/server/cli/", line 4, in <module>
    from .launch import launch
  File "/usr/local/lib/python3.8/dist-packages/server/cli/", line 12, in <module>
    from import Server
  File "/usr/local/lib/python3.8/dist-packages/server/app/", line 20, in <module>
    from flask_restful import Api, Resource
  File "/usr/local/lib/python3.8/dist-packages/flask_restful/", line 14, in <module>
    from flask.helpers import _endpoint_from_view_func
ImportError: cannot import name '_endpoint_from_view_func' from 'flask.helpers' (/usr/local/lib/python3.8/dist-packages/flask/

Version (please complete the following information):

  • Version [e.g. 0.13.0]: 0.16.7

Additional context

As official Dockerfile depends on pulling cellxgene through PIP, the same error happens inside Docker/Kubernetes deployments.

Issue Analytics

  • State:closed
  • Created 2 years ago
  • Comments:6

github_iconTop GitHub Comments

MaximilianLombardocommented, May 12, 2021

Hey thank you for using cellxgene and for your question.

We had a couple other users who had the same problem (find the discussion here) and it appears to be because a couple of cellxgene’s dependencies had major releases yesterday. We are still looking at the issue, but could you try installing these specific versions of your dependencies:

pip install -U flask==1.1.2 flatbuffers==1.12

Let me know if this solves your problem!

MaximilianLombardocommented, Jun 1, 2021

Hi all, this issue has been fixed with the latest release, closing this issue

Read more comments on GitHub >

github_iconTop Results From Across the Web

How to Fix ImportError: Cannot Import Name in Python - Rollbar
The Python ImportError: cannot import name error occurs when an imported class is not accessible or is in a circular dependency.
Read more >
cannot import name '_unicodefun' from 'click') · Issue #2964 ...
Describe the bug. The Github Action step: - name: Run black uses: psf/black@stable with: options: "--check --diff" version: "22.1.0".
Read more >
How to fix "ImportError: No module named ..." error in Python?
Add a script called in /home/bodacydo/work/project and edit it like this: import programs.my_python_program programs.my_python_program.main(). (replace ...
Read more >
ProductIO import error using snappy - python - STEP Forum
Good afternoon everyone, As I'm new to SNAP, I have encountered some issues. I'm trying to access to SNAP process via Python scripts....
Read more >
Error when importing TensorFlow | Apple Developer Forums
For me it was solved when ensuring that the dependencies and tensor flow itself are the same version! Right now that's actually 2.9.0...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found