Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Unable to find dependency with gradle

See original GitHub issue

Hi, up until now we were using this library in one of our Spring applications, specifically the following commit:

implementation ‘com.github.ChargeTimeEU:Java-OCA-OCPP:a67719e’

Now we need to implement GetCompositeSchedule and need a newer commit. We tried to use the latest commit on master:

implementation ‘com.github.ChargeTimeEU:Java-OCA-OCPP:75671a2’

and a few other earlier commits.

None of these commits worked for us as gradle does not find the dependency.

Looking at Jitpack we saw that on the master-SNAPSHOT branch the logfile has the following error:

> Task :OCPP-J:verifyGoogleJavaFormat FAILED

The following files are not formatted properly:


FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':OCPP-J:verifyGoogleJavaFormat'.
> Problems: formatting style violations

Could this be the issue for gradle not finding the dependency or is something wrong on our side?

Maybe you already know this issue and could point us in the right direction to help and fix it?


Issue Analytics

  • State:closed
  • Created 3 years ago
  • Comments:16 (9 by maintainers)

github_iconTop GitHub Comments

TVoldencommented, May 24, 2020

Hi @robinroscher

Does that mean that this issue is resolved? If so, can I get you to close it?

Sincerely, Thomas

robinroschercommented, May 20, 2020

I don’t know what happened there, now I also see it green and can pull it!

Read more comments on GitHub >

github_iconTop Results From Across the Web

gradle - not able to find dependencies from maven repo
I'm not sure what went wrong, but try to check if maven and gradle are using the same .m2 repository path. It should...
Read more >
Compile Successful; can't find dependency in local repository?
The only repository you have configured is maven central, so that is the only place Gradle is going to look. Gradle does not...
Read more >
IDEA Can't Find Dependencies for Gradle Configurations ...
And the reason I'm doing this is: Whenever you have Gradle custom source Set (generated for instance) and configure compileJava.options.
Read more >
project :app Search in build.gradle files. Fixed - YouTube
How to resolve an issue when dependency in android studio not found error.Simple and easy must watch.
Read more >
Gradle build issue, cannot find dependency - MBIENTLAB
Starting from today, I have a build error in android gradle: > Could not find com.mbientlab:metawear:3.8.1. Required by: project :app.
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found