Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

gulp-flowtype is not working for me. Not finding errors. Long running time.

See original GitHub issue

I am not sure why, when I use gulp-typeflow it takes 12s to run the code and it finds 0 erros, while running “flow” command finds errors missed by gulp-typeflow.

I’ve replaced gulp meanwhile to work with regular ‘flow’ cmd command which works with the .flowconfig settings

Previous flow task ( with gulp-flowtype )

gulp.task('flowtypeSrc', () =>
      all: true,
      weak: false,
      declarations: './flow-typed/npm',
      killFlow: false,
      beep: true,
      abort: true,
    })) // Add Flow here

Output: … ✔ Flow has found 0 errors [12:22:05] Finished ‘flowtypeSrc’ after 11 s …

Actually fails to find erros… and runs 11 seconds.

My current flow task:

gulp.task('flowtypeSrc', () => {
  try {
    execSync('./node_modules/.bin/flow', { stdio: 'inherit' });
  } catch (e) {

Output: … Found 1 error [12:14:17] Finished ‘flowtypeSrc’ after 308 ms …

I hope to contribute when I get the time, meanwhile this is a valid solution for others with the same problem.

Issue Analytics

  • State:open
  • Created 7 years ago
  • Reactions:4
  • Comments:10 (1 by maintainers)

github_iconTop GitHub Comments

alexei-bykovskicommented, Mar 7, 2018

Seems to be a problem in the executable flow file that is located in node_modules/gulp-flowtype/node_modules/flow-bin/vendor/flow. Solved this problem by installing flow-bin yarn add --dev flow-bin and pointing the path to flow process.env.FLOW_BIN = path.resolve(__dirname, 'node_modules/.bin/flow'). Now everything works like a charm.

saginadircommented, Nov 26, 2017

@alexxmde Gotcha Alex 😃 nice find.

This library seems unmaintained for several years, and it has it’s reasons

  1. Gulp is not as used anymore - webpack does a lot of the work these days with the -w flag that watches for changes and recompiles
  2. Most tools come with -w flag that reruns on file change and makes gulp further obsolete
  3. npm can have custom scripts which you can run like “npm run install” or “npm run build” and it further obsoletes gulp
  4. I was just using flow in my JetBrains IDE which gives you the errors in the IDE

But still nice catch 😃 brings me peace to know it’s solved.

Read more comments on GitHub >

github_iconTop Results From Across the Web

Issues · charliedowler/gulp-flowtype - GitHub
busts_in_silhouette: Run Facebook's Flow in your gulp pipeline - Issues ... gulp-flowtype is not working for me. Not finding errors. Long running time....
Read more >
charliedowler/gulp-flowtype - Gitter
When not using that option, it takes 5s to run the first time and then around ... I'm getting Fatal error: exception Failure(".flowconfig:5...
Read more >
Long-running Dataflow job fails with no errors in user code
I was having the same problem and it was solved by scaling up my workers resources. Specifically, I set --machine_type=n1-highcpu-96 in my ...
Read more >
Employees are not allowed to record their work time until they have actually worked it. Some employees think it is okay to record...
Read more >
ESP32-CAM Troubleshooting Guide: Most Common Problems ...
This error means that the ESP32-CAM is not in flashing mode or it is not ... What worked for me was first flashing...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found