Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

usb.core.USBError: [Errno 32] Pipe error

See original GitHub issue

Hi Charlysan, I’ve install you library and trying to run it failed :

root@orangepipcplus:~/pyrfidhid-master# python examples/ 
Initializing device...
Traceback (most recent call last):
  File "examples/", line 76, in <module>
  File "examples/", line 48, in main
  File "build/bdist.linux-armv7l/egg/rfidhid/", line 58, in init
  File "build/bdist.linux-armv7l/egg/rfidhid/", line 43, in get_report_descriptor
  File "build/bdist.linux-armv7l/egg/usb/", line 173, in get_descriptor
  File "build/bdist.linux-armv7l/egg/usb/", line 1043, in ctrl_transfer
  File "build/bdist.linux-armv7l/egg/usb/backend/", line 883, in ctrl_transfer
  File "build/bdist.linux-armv7l/egg/usb/backend/", line 595, in _check
usb.core.USBError: [Errno 32] Pipe error

I’ve also tried on my own desktop, and it is failing with the same stacktrace … Any idea ?

Issue Analytics

  • State:closed
  • Created 4 years ago
  • Comments:12 (7 by maintainers)

github_iconTop GitHub Comments

charlysancommented, Dec 1, 2019

@lhlong, sorry for the delay; I missed your last post. I’ve been using pyusb 1.0.2. Same question for you, does your device work with IDRW v3 windows app?

charlysancommented, Nov 14, 2020

I’m closing this issue as all the errors described above seem to be related to unsupported devices. I’ve included better error handling in version v1.1.4, so you should see now a more verbose error message for any core.usb.USBError exceptions.

Read more comments on GitHub >

github_iconTop Results From Across the Web

usb.core.USBError: [Errno 32] Pipe error after some time
Hello,. I'm getting this error while reading. The communication works fine for about 3 minutes and then this is triggered. I'm using an...
Read more >
python - Device Not Available on PyUSB
USBError: [Errno 32] Pipe error . I imagine this is because python was busy trying to do something or needed to be disconnected....
Read more >
usb.core.USBError: [Errno 32] Pipe error
Hi, I've recently got hold of 2 Crazyradio PA's to see if they would be suitable for a personal project. I've then tried...
Read more >
USB pipe error, both from Python and Ruby implementations
Sometimes very quick, sometimes after a couple of hours, I encounter an USB error: “[Errno 32] Pipe error”. This time it happens from...
Read more >
[pyusb-users] usb.core.USBError: [Errno 32] Pipe error
Hi! I'm using Ubuntu 12.04 development machine, Epson LX-300. I have followed the tutorial from Git, was able to find my printer but...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found