question-mark
Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

componentWillUpdate has been renamed,

See original GitHub issue

Warning: componentWillUpdate has been renamed, and is not recommended for use. See https://fb.me/react-async-component-lifecycle-hooks for details.

  • Move data fetching code or side effects to componentDidUpdate.
  • Rename componentWillUpdate to UNSAFE_componentWillUpdate to suppress this warning in non-strict mode. In React 17.x, only the UNSAFE_ name will work. To rename all deprecated lifecycles to their new names, you can run npx react-codemod rename-unsafe-lifecycles in your project source folder.

Please update the following components: Lottie

Issue Analytics

  • State:open
  • Created 4 years ago
  • Reactions:33
  • Comments:6

github_iconTop GitHub Comments

51reactions
lazysergeycommented, Nov 27, 2019

@thomazcapra @fake230 @graemeblackwood we forked this, added typescript and rewrote some parts so now it fits current lottie-web typings/naming. see https://github.com/crello/react-lottie

15reactions
mificommented, Jul 12, 2020

I never got any of the existing lottie-web React wrappers to correctly react to changes in props and properly play segments. So I made a complete rewrite using modern hooks only: react-lottie-player. No more deprecation warnings!

Read more comments on GitHub >

github_iconTop Results From Across the Web

Warning: componentWillMount has been Renamed, and is not ...
Learn what causes "Warning: componentWillMount has been renamed, and is not recommended for use."
Read more >
reactjs - componentWillReceiveProps has been renamed
componentWillReceiveProps has been renamed · Move data fetching code or side effects to componentDidUpdate. · If you're updating state whenever ...
Read more >
componentWillReceiveProps has been renamed - React Studio
Move data fetching code or side effects to componentDidUpdate. · Rename componentWillReceiveProps to UNSAFE_componentWillReceiveProps to suppress this warning in ...
Read more >
componentwillmount has been renamed, and is not ... - You.com
You're getting this warning because componentWillMount is deprecated in newer React versions. If you're not using componentWillMount anywhere then one of your ...
Read more >
[Warning] componentWillReceiveProps has been renamed ...
componentWillReceiveProps => componentDidUpdate 로 변경하면 해결된다. ​. ​. ​. 출처 : https://ko.reactjs.org/docs/react-component.html#updating.
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Dev.to Post

No results found

github_iconTop Related Hashnode Post

No results found