Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Config syntax error on startup

See original GitHub issue

Just updated to the latest release, The docker wont launch instead will exit, below is the log output,

epicgames-freegames-node@4.0.0 entrypoint-config /usr/app node dist/src/entrypoint-config.js

/usr/app/node_modules/json5/lib/parse.js:1083 const err = new SyntaxError(message)

SyntaxError: JSON5: invalid character ‘"’ at 11:5 at syntaxError (/usr/app/node_modules/json5/lib/parse.js:1083:17) at invalidChar (/usr/app/node_modules/json5/lib/parse.js:1028:12) at Object.afterPropertyValue (/usr/app/node_modules/json5/lib/parse.js:654:15) at Object.default (/usr/app/node_modules/json5/lib/parse.js:146:37) at lex (/usr/app/node_modules/json5/lib/parse.js:78:42) at Object.parse (/usr/app/node_modules/json5/lib/parse.js:25:17) at Object.<anonymous> (/usr/app/src/common/config/setup.ts:56:30) at Module._compile (internal/modules/cjs/loader.js:1085:14) at Object.Module._extensions…js (internal/modules/cjs/loader.js:1114:10) at Module.load (internal/modules/cjs/loader.js:950:32) npm ERR! code ELIFECYCLE npm ERR! errno 1 npm ERR! epicgames-freegames-node@4.0.0 entrypoint-config: node dist/src/entrypoint-config.js npm ERR! Exit status 1

npm ERR! Failed at the epicgames-freegames-node@4.0.0 entrypoint-config script.

npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in: npm ERR! /root/.npm/_logs/2021-10-03T02_27_45_193Z-debug.log cat: can’t open ‘/tmp/config.json’: No such file or directory cat: can’t open ‘/tmp/config.json’: No such file or directory cat: can’t open ‘/tmp/config.json’: No such file or directory cat: can’t open ‘/tmp/config.json’: No such file or directory Setting timezone: Run on startup: Run once: Exiting…

Issue Analytics

  • State:closed
  • Created 2 years ago
  • Comments:11 (5 by maintainers)

github_iconTop GitHub Comments

claabscommented, Oct 3, 2021

SyntaxError: JSON5: invalid character ‘"’ at 11:5

You have an syntax error in your config.json(5) at line 11, column 5.

Cexitimecommented, Oct 8, 2021

Oh how frustrating! I have solved it, I also encountered another error of a ‘not a valid web address’, solved this by putting http in front of the IP address for the web url and now everything is working nicely 😃

Hopefully I wont break anything else by missing a comma.

Read more comments on GitHub >

github_iconTop Results From Across the Web

Syntax error in documented config file · Issue #4748 - GitHub
I'm trying this work-around to get the proxy in transparent mode to redirect traffic originating from the machine itself correctly.
Read more >
Apache Configuration Error AH00526: Syntax error
An Apache AH00526: Syntax error message occurs when there is a typo or misconfigured setting somewhere in your Apache configuration files.
Read more >
the configuration file contains a syntax error on line 14
I found the Solution. Go to C:\wamp64. Run restart_wampserver.bat. Problem Solved.
Read more >
How to fix a syntax error in Grub? - Unix & Linux Stack Exchange
I want to update my grub settings. I get the following message # grub-mkconfig -o /boot/grub/grub.cfg Generating grub configuration file ...
Read more >
i3 config file error at startup : r/EndeavourOS - Reddit
First part of error communicates that it was expecting "one of these tokens:... [list of correct tokens/keywords]. Instead it got ~/.config/i3/ ...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found