Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Kerberos Auth connection attempt results in Server Not Found in Kerberos database error

See original GitHub issue

We are trying to connect to a kerberized cluster using Impyla. When trying to connect, we get a vague error message.

conn = connect(host='',port=10000,auth_mechanism='GSSAPI',kerberos_service_name='hive/')

Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/opt/venv/COUNTACH/lib/python2.7/site-packages/impala/", line 147, in connect
  File "/opt/venv/COUNTACH/lib/python2.7/site-packages/impala/", line 758, in connect
  File "/opt/venv/COUNTACH/lib/python2.7/site-packages/thrift_sasl/", line 72, in open
    message=("Could not start SASL: %s" % self.sasl.getError()))
thrift.transport.TTransport.TTransportException: Could not start SASL: Error in sasl_client_start (-1) SASL(-1): generic failure: GSSAPI Error: Unspecified GSS failure.  Minor code may provide more information (Server not found in Kerberos database)

We are able to use the same kerberos service principle and host for Beeline and connect successfully. I saw another post mentioning this same issue, but no resolution was given (Issue #149).


impyla      0.14.0
sasl        0.2.1
six         1.10.0
thrift      0.10.0
thrift-sasl 0.2.1

Any help or suggestions would be greatly appreciated. We are at a loss as to whether it is a bug or a configuration issue or something else.

Thanks, Jason

Issue Analytics

  • State:open
  • Created 6 years ago
  • Reactions:5
  • Comments:13 (1 by maintainers)

github_iconTop GitHub Comments

sathishsmscommented, May 8, 2018

Facing the same issue. what could be the problem ? “msg”: “kerberos: authGSSClientStep() failed: ((‘Unspecified GSS failure. Minor code may provide more information’, 851968), (‘Server not found in Kerberos database’, -1765328377))”,

rohit6261commented, Dec 30, 2020

Is this issue resolved? As i am getting the same error. Please help

Read more comments on GitHub >

github_iconTop Results From Across the Web

Cannot get Kerberos service ticket: KrbException: Server not ...
"Server not found in Kerberos database" error can happen if you have registered the SPN to multiple users/computers ...
Read more >
active directory - Server Not Found in Kerberos database
This seems to be the culprit: error Message is Server not found in Kerberos database sname is cifs/***********@***********.
Read more >
Solved: Getting "Server not found in Kerberos database" wh...
Solved: Hi, First a couple of things that work : -Nifi cluster running on 3 nodes (running Apache upstream - 209569.
Read more >
"Server not found in kerberos database" when ... - ERROR
If service principal and user principal are not set to the same value, then you will be able to perform “kinit” but getting...
Read more >
4768(S, F) A Kerberos authentication ticket (TGT) was requested
This error can occur if the domain controller cannot find the server's name in Active Directory. This error is similar to ...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found