Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Error on first run

See original GitHub issue


I ran make build withour any error. Then i tested make start and got this error :

docker run --name flan_1574936755 -v /tmp/flan/shared:/shared flan_scan
mkdir: can't create directory '/shared/xml_files/2019.11.28-10.25': No such file or directory
/ line 34: can't open /shared/ips.txt: no such file
Traceback (most recent call last):
  File "/", line 238, in <module>
  File "/", line 224, in main
    for i, filename in enumerate(os.listdir(dirname)):
FileNotFoundError: [Errno 2] No such file or directory: '/shared/xml_files/2019.11.28-10.25'
sed: /shared/reports/report_2019.11.28-10.25.tex: No such file or directory
sed: /shared/reports/report_2019.11.28-10.25.tex: No such file or directory
sed: /shared/reports/report_2019.11.28-10.25.tex: No such file or directory
sed: /shared/reports/report_2019.11.28-10.25.tex: No such file or directory

Issue Analytics

  • State:open
  • Created 4 years ago
  • Reactions:1
  • Comments:16 (1 by maintainers)

github_iconTop GitHub Comments

sebelkcommented, Jun 23, 2021

I’ve found that chmoding with 777 and directories under shared it works, is that the expected behaviour?

root360-AndreasUlmcommented, Nov 28, 2019

Did you use the folder structure provided by ‘shared’-folder in the git to initialize your ‘/tmp/flan/shared’?

If not than that’s the reason because the run logic currently expects that the shared folder has the following content:

  • ips.txt (= list of IPs to be scanned)
  • xml_files/ (= folder to store nmap scan results)
  • reports/ (= folder to store latex reports)
Read more comments on GitHub >

github_iconTop Results From Across the Web

JavaScript - error on first run, second run is fine - Stack Overflow
When I run it once from the console I get: Uncaught TypeError: Cannot read property 'length' of undefined(…).
Read more >
Error on first Run - Support - 3D Slicer Community
This laptop was released a year or so ago, so Slicer can run on it. Configure the graphics settings so the Slicer can...
Read more >
Error on first run - Veeam R&D Forums
Error is: "The user name or password is incorrect. Failed to process [isFileExists]. Backing up to shared folder on Synology DS916+ NAS. My ......
Read more >
SAP message F5316 First run is in the past
Even though this error message does not provide any useful or additional message details, you can still try to solve the issue by...
Read more >
Script run in RStudio now halts on first error
Hello, I have recently found that all scripts run in RStudio are now stopping on the first error instead of throwing the message...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found