Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Webpack warning when running examples

See original GitHub issue

I am trying to run the doca examples using the following commands:

lerna -v
node -v
git clone
cd json-schema-tools
lerna bootstrap
cd workspaces/doca/example-schemas/draft-04
doca init
cd documentation
../../../../../scripts/yarn/bin/yarn install
../../../../../scripts/yarn/bin/yarn start

But I get warnings from webpack and the resulting webpage is only very minimally styled. The output from the above is:

Cloning into 'json-schema-tools'...
remote: Counting objects: 883, done.
remote: Compressing objects: 100% (390/390), done.
remote: Total 883 (delta 471), reused 862 (delta 451), pack-reused 0
Receiving objects: 100% (883/883), 1.26 MiB | 1.98 MiB/s, done.
Resolving deltas: 100% (471/471), done.
lerna info version 2.11.0
lerna info versioning independent
lerna info Bootstrapping 7 packages
lerna info hoist Finished installing in root
lerna success Bootstrapped 7 packages
Folder documentation has been created.
Importing these schemas from .:
- common/collection.json
- common/identifier.json
- solarsystem/definitions/measurements.json
- solarsystem/definitions/orbit.json
- solarsystem/definitions/planet.json
- solarsystem/dwarfplanet.json
- solarsystem/planet.json
- solarsystem/probe.json
- solarsystem/sun.json
Doca project files has been copied!
Customizing doca project files:
Trying to yarn add @cloudflare/doca-default-theme for project documentation...
Theme @cloudflare/doca-default-theme at documentation has been successfully installed!
Setting documentation theme to @cloudflare/doca-default-theme. Files changed:
yarn install v1.3.2
[1/5] 🔍  Validating package.json...
[2/5] 🔍  Resolving packages...
success Already up-to-date.
✨  Done in 0.50s.
yarn run v1.3.2
$ node webpack/index | NODE_ENV=development node src/server
Server started on port 8000
⚠ 「wdm」: Hash: c48508533cd4cb5aaf7c
Version: webpack 3.12.0
Time: 1817ms
 Asset     Size  Chunks                    Chunk Names
app.js  4.04 MB       0  [emitted]  [big]  app
  [14] ./node_modules/react/react.js 56 bytes {0} [built]
  [33] (webpack)/buildin/module.js 517 bytes {0} [built]
  [81] ./schemas.js 635 bytes {0} [built]
  [91] ./node_modules/react-dom/index.js 59 bytes {0} [built]
 [117] ./node_modules/react-redux/es/index.js 230 bytes {0} [built]
 [154] multi webpack-hot-middleware/client?path= ./src/client/index.js 40 bytes {0} [built]
 [155] (webpack)-hot-middleware/client.js?path= 7.77 kB {0} [built]
 [156] ./node_modules/querystring-es3/index.js 127 bytes {0} [built]
 [159] ./node_modules/strip-ansi/index.js 161 bytes {0} [built]
 [161] (webpack)-hot-middleware/client-overlay.js 2.21 kB {0} [built]
 [166] (webpack)-hot-middleware/process-update.js 4.33 kB {0} [built]
 [167] ./src/client/index.js 710 bytes {0} [built]
 [292] ./src/client/main.js 1.27 kB {0} [built]
 [293] ./node_modules/@cloudflare/doca-default-theme/index.js 100 bytes {0} [built]
 [413] ./src/client/store.js 1.42 kB {0} [built]
    + 406 hidden modules

WARNING in ./src/client/main.js
23:15-89 Critical dependency: Contexts can't use RegExps with the 'g' or 'y' flags.
 @ ./src/client/main.js
 @ ./src/client/index.js
 @ multi webpack-hot-middleware/client?path= ./src/client/index.js

WARNING in ./src/client/main.js
25:16-91 Critical dependency: Contexts can't use RegExps with the 'g' or 'y' flags.
 @ ./src/client/main.js
 @ ./src/client/index.js
 @ multi webpack-hot-middleware/client?path= ./src/client/index.js

WARNING in ./src/client/main.js
27:16-91 Critical dependency: Contexts can't use RegExps with the 'g' or 'y' flags.
 @ ./src/client/main.js
 @ ./src/client/index.js
 @ multi webpack-hot-middleware/client?path= ./src/client/index.js

This is using macOS 10.13.1

Is it something I’m doing wrong?

Issue Analytics

  • State:open
  • Created 5 years ago
  • Comments:9 (3 by maintainers)

github_iconTop GitHub Comments

rscreenecommented, May 22, 2018

Ah, I had assumed that the warnings were the reason that there was no CSS! I’ll check back later.

Nice project by the way!

genetique-technocommented, May 21, 2018

@handrews thanks for providing some background on the state of things–I totally understand Real Life. I’m going to try to make a new template with the draft-07, and I’ll hit up the slack for any issues that come up. Thanks again and best of luck with Real Life.

Read more comments on GitHub >

github_iconTop Results From Across the Web

How I solved and debugged my Webpack issue through trial ...
So I tried to set up the source maps as described in the docs by adding devtool. When webpack bundles your source code,...
Read more >
Command Line Interface - webpack
webpack is a module bundler. Its main purpose is to bundle JavaScript files for usage in a browser, yet it is also capable...
Read more >
Webpack - Critical dependency: the request of a dependency ...
I am getting three warning messages when importing request in a barebone webpack project. A minimal example to reproduce the bug is ...
Read more >
ts-loader - npm
TypeScript loader for webpack. Latest version: 9.4.2, last published: a month ago. Start using ts-loader in your project by running `npm i ...
Read more >
Troubleshooting - SurviveJS
Using webpack can lead to a variety of runtime warnings or errors. Often a particular part of the build fails for a reason...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found