Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Possible issues with buildpack with Mediawiki

See original GitHub issue

What version of Cloud Foundry and CF CLI are you using? (i.e. What is the output of running cf curl /v2/info && cf version?

{ “name”: “Bluemix”, “build”: “270030”, “support”: “”, “version”: 0, “description”: “IBM Bluemix”, “authorization_endpoint”: “”, “token_endpoint”: “”, “min_cli_version”: null, “min_recommended_cli_version”: null, “api_version”: “2.92.0”, “app_ssh_endpoint”: “”, “app_ssh_host_key_fingerprint”: “b6:98:0b:3e:33:1e:c1:51:1b:3f:06:6e:3f:da:6f:d9”, “app_ssh_oauth_client”: “ssh-proxy”, “doppler_logging_endpoint”: “wss://” }

cf version 6.41.0+dd4c76cdd.2018-11-28

What version of the buildpack you are using? 4.3.78 (

If you were attempting to accomplish a task, what was it you were attempting to do?

I was attempting to install Mediawiki 1.32.2 by following their basic installation guide on their page, however, I run into “MediaWiki now also has some external dependencies that need to be installed via composer or from a separate git repo. Please see for help on installing the required components.”

Upon several googling I found a guide that told me to remove a specific file ( I forgot what it was and can’t find the link) and it allowed me to get past this issue but then I had the issues that I was missing the extensions mbstring, & fileinfo.

To see if this was just me failing to install Mediawiki, I tried to install phpMyAdmin, and I run into the issues that mysqli extension is also missing.

However, I have installed both MediaWiki and phpMyAdmin locally without any issues…so I am wondering if it could be the build pack, as I am trying to replicate an app someone had previously created. They use the same Mediawiki software but under build pack on cloud foundry it just says “no runtime” instead of “PHP_BUILDPACK”

I have tried following comments from this link but no luck:

What did you expect to happen?

I expected to run into the media wiki install page. I did this locally to confirm I was doing the right steps and and I got successfully to the installation page.

What was the actual behavior?

I get the error that I must use composer to install external dependencies but I did…

Please confirm where necessary:

  • I have included a log output
  • My log includes an error message
  • I have included steps for reproduction

Issue Analytics

  • State:closed
  • Created 4 years ago
  • Comments:9

github_iconTop GitHub Comments

dmikusacommented, Jun 18, 2019

There may be multiple things going on here. It’s hard to tell though as there’s not a lot of detailed info here.

If you’re missing extensions, then you likely just need to add an ini snippet and tell PHP to load them. All the ones you mentioned are included with the buildpack but not turned on by default.

As far as the other issues, try what’s on #214 again and try to be more specific about documenting what you’re doing. Include error messages & logs as well as the specific configuration that you’re using.

Hope that helps!

dgarci10commented, Jun 19, 2019


I was able to fix the directory and be able to successfully get to the install page. Thanks so much for your patience!

Read more comments on GitHub >

github_iconTop Results From Across the Web

New URL → Issues with VisualEditor on a shared host
I'm having trouble in recreating the Parsoid app, ... Select Node.js (ok and changes saved: "Your new buildpack configuration will be used ...
Read more >
MediaWiki installation on Pivotal Cloud Foundry - GitHub
In the example shown below, I'm creating a route that applies to PWS (e.g. using the domain) and I'm binding the mediawiki...
Read more >
heroku -mediawiki-buildpack. Buildpack to deploy mediawiki at heroku. CLI Installation. Copy the snippet above into CLI. CLI Install Details View on GitHub.
Read more >
How can I deploy MediaWiki on Heroku? - Quora
I assume you are trying to deploy a wiki that uses the same software as Wikipedia not a clone of all the data...
Read more >
MediaWiki on Heroku: mbstring, intl PHP extensions missing
1 requires ext-mbstring * -> it is missing from your system. Install or enable PHP's mbstring extension. Problem 3 - Root composer.json requires ......
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found