Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Cannot make extension work - I think...

See original GitHub issue

Hello, thank you for helping. I am kind of confused on how to make this extension work. I added the following lines of code into my .vimrc:

call plug#begin("~/vimfiles/plugged")
Plug 'coc-extensions/coc-omnisharp'     "<-- I think this should not even be here, I tested it with and without it being here
Plug 'neoclide/coc.nvim', {'branch': 'release'}
call plug#end()

let coc_global_extensions = ['coc-omnisharp']

I also used the command :CocInstall coc-omnisharp just to be on the save side. The extension seems to be installed, here is the output of CocList extensions: image

But there is still no autocompletion and still no syntax highlighting. If I install the omnisharp-vim plugin, then it works, but I would like to manage all language servers through coc.

Am I missing something here? Do I have to set some language server settings like here?

Issue Analytics

  • State:closed
  • Created 3 years ago
  • Comments:9 (3 by maintainers)

github_iconTop GitHub Comments

eruizc-devcommented, Dec 10, 2020

Can I use an older version to get around this error for the time being?

Open :CocConfig and set omnisharp.version to v1.37.3 (or older)

    "omnisharp.version": "v1.37.3"

Then delete the coc-omnisharp-data folder found in one of the next locations. Next time you open a .cs file it will download the specified version.

  • ~/.config/coc/extensions/coc-omnisharp-data/
  • ~/.coc/extensions/coc-omnisharp-data/
  • ~/AppData/Local/coc/extensions/coc-omnisharp-data

If it’s not located in any of the above, you can run :CocList extensions and search for coc-omnisharp to get an idea where it could be located: It’s always after coc/extensions/.

If the download instantly stops it’s probably because you misspelled the version. It should be exactly as the title of any of these releases or latest.

yatlicommented, Nov 29, 2020

Roger roger. Will ping you on this thread.

Read more comments on GitHub >

github_iconTop Results From Across the Web

How to Fix Chrome Extensions Not Loading or Crashing
As good as it is, sometimes Chrome has some problems. Here's how to fix Chrome extensions that won't load or keep crashing.
Read more >
Fix problems with apps, extensions, or themes - Chrome Web ...
At the top right, click Settings. My Extensions & Apps. Click the app, extension, or theme. In the box that appears, at the...
Read more >
Can't File by the Deadline? Top 3 Reasons to File a Tax ...
Filing a tax extension is free, easy and automatic: Just submit Form 4868 electronically or on paper by the filing deadline. TurboTax Easy ......
Read more >
Topic No. 304 Extensions of Time to File Your Tax Return - IRS
You may request up to an additional 6 months to file your U.S. individual income tax return. There are three ways to request...
Read more >
Cannot make R-extension work in NetLogo - Stack Overflow
The 'Check java' tool reports that I have v1. 8.0_51 and v1. 6.0_45 installed and that if one is 32bit and the other...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found