Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Unable to run tests - Loading botium plugin failed for directline3

See original GitHub issue


I am attempting to test against direclist

Running: ubuntu -16.04 Node -10.15.0 Npm 6.4.1 Step by step what I did:

I installed botium-cli: npm i botium-cli -g Where this is my package.json: { "name": "botium", "version": "1.0.0", "description": "", "main": "index.js", "scripts": { "emulator": "botium-cli emulator console --convos ./spec/convos --config ./botium.json", "emulatorBrowser": "botium-cli emulator browser --convos ./spec/convos --config ./botium.json" }, "author": "", "license": "ISC" }

And this is my botium.json:

{ "botium":{ "Capabilities":{ "PROJECTNAME":"", "CONTAINERMODE":"directline3", "DIRECTLINE3_SECRET":", "DIRECTLINE3_WEBSOCKET":true, "DIRECTLINE3_POLLINGINTERVAL":1000 }, "Sources": {}, "Envs": { "NODE_TLS_REJECT_UNAUTHORIZED": 0 } } }

And i Wrote a file botiumFluent.json file

const BotDriver = require('botium-core').BotDriver const driver = new BotDriver() driver.BuildFluent() .Start() .UserSaysText('Hello') .WaitBotSaysText(console.log) .WaitBotSays((msg) => console.log(JSON.stringify(msg, null, 2))) .WaitBotSays((msg) => console.log(JSON.stringify(msg, null, 2))) .WaitBotSays((msg) => console.log(JSON.stringify(msg, null, 2))) .WaitBotSays((msg) => console.log(JSON.stringify(msg, null, 2))) .Stop() .Clean() .Exec() .then(() => { console.log('READY') }) .catch((err) => { console.log('ERROR: ', err) })

I used the command to run this file as “node botiumFluent.js” and it gives and error saying “ERROR: Error: Loading Botium plugin failed at Validate.Validate.then (/home/vivekb/tamara/tamara-example/node_modules/botium-core/src/containers/PluginConnectorContainer.js:56:15)”

Issue Analytics

  • State:closed
  • Created 5 years ago
  • Comments:10 (5 by maintainers)

github_iconTop GitHub Comments

vivekbrahmadandicommented, Jan 17, 2019

it worked after installing npm package called npm install -g botium-connector-directline3

vivekbrahmadandicommented, Jan 17, 2019

thanks for helping out

Read more comments on GitHub >

github_iconTop Results From Across the Web

Problem with botium installation
Hi everybody! here again with some problems :frowning: Steps: brand new machine, node installation node version v12.21.0 npm version 6.14.11 ...
Read more >
Getting "Loading Botium plugin from directline3" even after ...
This issue got resolved after I ran npm install -g botium-core.
Read more >
Botium documentation
Botium Platform: Everything you need to run Botium in the Enterprise . ... name for the test case to make it easier for...
Read more >
Botium in a Nutshell, Part 3: Automating Chatbot Tests
You can validate your configuration settings by using the Botium CLI — it opens a REPL-interface for you, so you can have a...
Read more >
botium-connector-directline3 - npm
Botium Connector for Bot Framework Direct Line 3 API. Latest version: 0.1.1, last published: 8 months ago. Start using ...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found