Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Android 10 storage not accessible

See original GitHub issue

I have been using this lib in my app for a few months now, and it has been working perfectly. Recently one of our partners updated their company phones to Android 10 and it broke this lib. When I open the dialog, it shows the storage options, but when I click on Internal Storage I get a toast saying The storage you have choosen is not accessible.. The app has storage read permission. I get no log message. What can be the problem? Is it the new scoped storage access?

Issue Analytics

  • State:open
  • Created 4 years ago
  • Reactions:2
  • Comments:5 (2 by maintainers)

github_iconTop GitHub Comments

koostamascommented, Jan 3, 2020

Adding android:requestLegacyExternalStorage="true" to the manifest solved my problem but this is only a temporary fix until Android 11 ® comes out because from that version on we will be forced to use the new Storage Access Framework. I didn’t close this issue because the above mentioned fix is only a workaround and does not solve the root of the problem.

sfilmakcommented, Mar 15, 2020

Hello. Any update on this issue? Still not fixed.

Read more comments on GitHub >

github_iconTop Results From Across the Web

Storage updates in Android 11 - Android Developers
If your app uses the legacy storage model and previously targeted Android 10 or lower, you might be storing data in a directory...
Read more >
How to Fix Insufficient Storage Available Error on Android
1. Open the Settings app. Open this by tapping the gear app icon in the App Drawer or from the Quick Panel (swipe...
Read more >
[SOLVED] How To Fix Insufficient Storage Available (Android)?
Solution 1: Clear App Cache to Free up Space on Android​​ In general, the lack of working space is probably the main cause...
Read more >
[HELP] Internal Storage not accessible - XDA Forums
And I keep getting this error message:" keeps stopping." I don't know if that's what causing it or ...
Read more >
Android Q (10) ask permission to get access all storage ...
File API is not available in android 10 for files in shared storage that your app does not own. ...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found