Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Connection fails with mpv, but works fine with mplayer

See original GitHub issue

OS: Raspberry Pi OS lite (latest, on a pi zero w)

Pyradio v0.8.9.16

All dependencies installed that you included in your PR ( ), using that script.

If I run pyradio, it says its using mpv, additionally which mpv tells me the binary exists OK on the system. But pyradio says connecting to..., and then it says connection failed when using mpv.

If I remove mpv from the system, and install mplayer instead, pyradio works OK, everything plays as expected, no problems.

Additionally (before un-installing mpv with apt), when I was in pyradio, I hit the c key, unchecked mpv checkbox, hit the s key, closed and restarted pyradio, but mpv was still selected with a checkmark when I opened the config window?

Issue Analytics

  • State:closed
  • Created 2 years ago
  • Comments:23

github_iconTop GitHub Comments

taoteh1221commented, Mar 21, 2022

Ok. Thanks for the PR and insight, it was very helpful! 😄 Most people may use a more powerful pi, the zero model is the weakest chipset…maybe why you never heard of mpv crashing before. Take care, thanks again! 😄

s-n-gcommented, Mar 21, 2022

I am curious as to why the issue

The only reason I can think of is that maybe this particular board is not strong enough to handle constantly opening and closing pipes… IDK…

I’ve had other people asking about rasberry and mpv (facing problems with the timeout value), but never anything like crashes and such…

Anyway, I think I’ll be closing this issue now, feel free to contact me if anything else pops up 😄

Read more comments on GitHub >

github_iconTop Results From Across the Web

Could I play sound files with mplayer or mpv? #135 - GitHub
In Termux, it is able to play sound files but in Userland I found it ... AO: [pulse] Init failed: Connection refused ......
Read more >
[SOLVED] smplayer doesn't play anything !!!
It seems that for some unknown reason smplayer can't start mpv. See if you can get the mpv logs from smplayer, or play...
Read more >
[solved] upgrade: mplayer black screen, vlc and smplayer ...
It seems today's upgrade screwed my mplayer. Plays audio but instead of video displays black screen. No matter what I try mplayer on....
Read more >
While using mpv as back-end of Smplayer, I can't use vdpau in ...
If you don't have a multicore processor: select Preferences in the Options menu. That will open the preferences dialog. Go to the Performance ......
Read more >
Unprecedented problem on Mplayer - Debian User Forums
I used to use Mplayer on a command-line terminal to listen to my ... (The streaming link works perfectly well on other software...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found