Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Not starting up on my server

See original GitHub issue

Issue Description

What’s happening? The bot used to start up, however it doesn’t anymore. All the tokens are still valid


> muse@2.1.0 start
npm run env:set-database-url -- esmo src/scripts/migrate-and-start.ts

> muse@2.1.0 env:set-database-url
> esmo src/scripts/run-with-database-url.ts
(node:446435) ExperimentalWarning: Custom ESM Loaders is an experimental feature. This feature could change at any time
(Use `node --trace-warnings ...` to show where the warning was created)
Error [ERR_LOADER_CHAIN_INCOMPLETE]: "file:///root/runner/private/lh-music/node_modules/esbuild-node-loader/loader.mjs 'resolve'" did not call the next hook in its chain and did not explicitly signal a short circuit. If this is intentional, include `shortCircuit: true` in the hook's return.
    at new NodeError (node:internal/errors:387:5)
    at ESMLoader.resolve (node:internal/modules/esm/loader:860:13 
    at async ESMLoader.getModuleJob (node:internal/modules/esm/loader:439:7)
    at async Promise.all (index 0)
    at async ESMLoader.import (node:internal/modules/esm/loader:541:24)
    at async loadESM (node:internal/process/esm_loader:83:5)
    at async handleMainPromise (node:internal/modules/run_main:65:12) {

Screenshots If applicable, add screenshots to help explain your problem.

Additional context Add any other context about the problem here.

Runtime I’m running Muse:

  • Directly from the cloned repository
  • Inside a Docker container
  • Something else (please elaborate)


  • Muse: 2.1.0 (the same issue occurs on 2.1.1 as well)
  • Docker (if applicable):
  • OS: Arch Linux
  • ffmpeg: (if running outside the Docker container, 4.1 or later is required) 5.0.1

Issue Analytics

  • State:closed
  • Created 7 months ago
  • Reactions:1
  • Comments:12 (3 by maintainers)

github_iconTop GitHub Comments

codethewebcommented, Aug 20, 2022

I was able to reproduce the issue and it should now be fixed in the above release.

chitinlinkcommented, Aug 15, 2022

Maybe try Node v16? (I haven’t tried v18, although I don’t see why that would be a problem.)

Switched to Node v16.16.0 and it works fine. No idea what in 18 would be doing this but it doesn’t matter

Read more comments on GitHub >

github_iconTop Results From Across the Web

My Server won't boot. What do I do? - Support Center
Operating System Check - Try booting into Safe Mode by using the F8 key on the keyboard so that Windows is able to...
Read more >
Unable to Start the Server Service - Microsoft Support
When you attempt to start the Server service from a command prompt, you may receive the following error message: System error 1058 has...
Read more >
Why Won't My Minecraft Server Start? - Apex Hosting
Your server not starting can be the result of a number of causes, in most cases, it can be resolved or at least...
Read more >
Dell PowerEdge: Troubleshooting a Server that does not start ...
If the operating system does not start for any reason, this is called a No Boot. A common symptom is also that there...
Read more >
[SOLVED] Help! Server won't start... - General Hardware Forum
Unplug the power supplies and then pull each power supply out and push it back in. No need to take the server apart....
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found