Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Fresh install of v3.2.16 fails to initialize

See original GitHub issue

please complete the following information:

  • OS version: Win 10
  • Editor version: 1.55.0
  • Programming language: ts
  • TabNine extension version: 3.2.16 & 3.2.15

If the issue is related to TabNine failure, please provide log files:

Type TabNine::config in your editor, the logs are located at the bottom of the page

Editor console logs:

Help -> Toggle Developer Tools

Issue Details:

So I tried installing the plugin for the first time today. I saw the ‘tabnine’ icon and name appear at the bottom of vs code in the status bar. But when I clicked it to open the tabnine hub, the page was simply blank. I tried restarting vs code, uninstalling and re-installing. No code completion was happening, and typing TabNine::config did nothing. I then tried rolling back one version to 3.2.15 to see if there was any difference, but the behavior was the same.

I then went all the way back and installed v3.1.26. This time it worked flawlessly. Tabnine hub initialized and I was finally getting completions. I then attempted to upgrade to the latest version, and it is working now.

Based on this, I imagine there is some sort of setup process that the newer version is wrongly expecting to already be there. The newer version probably works for most people if they already have a 3.1.x version installed. However a fresh installation appears to be broken, at least in the two most recent versions as of writing this issue.

Issue Analytics

  • State:closed
  • Created 2 years ago
  • Comments:12 (4 by maintainers)

github_iconTop GitHub Comments

rossignollicommented, Apr 1, 2021

@dimacodota Everything seems to be working now! Good job!

dimacodotacommented, Apr 1, 2021

@rossignolli @Jonovono @tbrixey - can you please send us your tabnine_config.json file to the file should be located at: window: {FOLDERID_RoamingAppData}\TabNine. C:\Users\Alice\AppData\Roaming\TabNine mac : $HOME/Library/Preferences/TabNine /Users/Alice/Library/Preferences/TabNine linux: $XDG_CONFIG_HOME/TabNine or $HOME/.config/TabNine /home/alice/.config

Read more comments on GitHub >

github_iconTop Results From Across the Web

Landing pages throwing 500 error after upgrade to 3.0.2 from ...
My Mautic version is: 3.0.2 My PHP version is: 7.2.30 After upgrading to Mautic 3.0.2, my landing pages are now throwing a 500...
Read more >
Upgrade to 2.16 Error Drupal\Core\Field\FieldException ...
Upgrade to 2.16 Error Drupal\Core\Field\FieldException: Attempt to create a configurable field of non-configurable field storage order_items.
Read more >
Error: Electron failed to install correctly, please delete ... - GitHub
I can not use Electron because it is not installed correctly, despite using the shell in administrator mode. Note that when installing ......
Read more >
Requires SDK version >=2.16.0 <3.0.0, version solving failed
My case was creating a project with master channel, an then change to stabel wich was a bit lower version. I Basically needed...
Read more >
Errors with new 2.16.1 patch release? -
install --system")? The install script should create a '.iraf' ... 3) this same error also happens if I do a personal level install...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found