Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

TabNine binary timeout

See original GitHub issue

Issue Description

please complete the following information:

  • OS version: macOS Monterey 12.4
  • Editor version [e.g. 1.45.0-insider]: Version: 1.69.2 (Universal) Commit: 3b889b090b5ad5793f524b5d1d39fda662b96a2a Date: 2022-07-18T16:12:57.074Z (5 days ago) Electron: 18.3.5 Chromium: 100.0.4896.160 Node.js: 16.13.2 V8: OS: Darwin arm64 21.5.0
  • Programming language: all
  • TabNine extension version: 3.6.5

If the issue is related to TabNine failure, please provide log files:

Editor console logs:

CRITI Extension 'tabnine.tabnine-vscode' wants API proposal 'inlineCompletions' but that proposal DOES NOT EXIST. Likely, the proposal has been finalized (check 'vscode.d.ts') or was abandoned.

ERR [Extension Host] validating /Users/james/Library/Application Support/Code/User/globalStorage/tabnine.tabnine-vscode/binaries/4.4.84/aarch64-apple-darwin/TabNine timeout

[Extension Host] validating /Users/james/Library/Application Support/Code/User/globalStorage/tabnine.tabnine-vscode/binaries/4.4.84/aarch64-apple-darwin/TabNine timeout

Issue Details: I am no longer receiving any hints from TabNine. The extension no longer appears in the footer toolbar.

Tried uninstalling, restarting and re-installing. Tried deleting /Users/james/Library/Application Support/Code/User/globalStorage/tabnine.tabnine-vscode/ and re-installing. Exact same problem remains.


Issue Analytics

  • State:closed
  • Created 7 months ago
  • Comments:8 (1 by maintainers)

github_iconTop GitHub Comments

jamesastoundcommented, Jul 25, 2022

I am closing this ticket. I. guess the ARM version doesn’t show any hints in the pop-up intellisense box, like the Intel. But I got the inline versions working by deleting everything and re-installing all my extensions. Still not sure what the hiccup was.

jamesastoundcommented, Jul 25, 2022

It did work, can’t recall when it stopped, tho. I’ve been running TabNine on the 2021 (ARM) since I opened my account in February.

Read more comments on GitHub >

github_iconTop Results From Across the Web

CouchbaseEnvironment.managementTimeout - Java - Tabnine
The default timeout for connect operations, set to DefaultCouchbaseEnvironment#CONNECT_TIMEOUT. shutdown · kvTimeout. The default timeout for binary (key/value) ...
Read more >
io.airlift.units.Duration.toString java code examples - Tabnine
isS3SslEnabled()); Duration connectTimeout = Duration.valueOf(conf.get(S3_CONNECT_TIMEOUT, defaults.getS3ConnectTimeout().
Read more >
okio.Timeout.timeout java code examples - Tabnine
Wait at most timeout time before aborting an operation. Using a per-operation timeout means that as long as forward progress is being made,...
Read more >
javax.websocket.WebSocketContainer ... - Tabnine
Set the default maximum buffer size (in bytes) for binary messages. setDefaultMaxSessionIdleTimeout. Set the current default session idle timeout in ...
Read more >
WebSocketPolicy.setAsyncWriteTimeout - Java - Tabnine
setAsyncWriteTimeout (Showing top 6 results out of 315) ... The maximum size of a binary message during parsing. This is a memory conservation...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found