Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Could not resolve eslint dependency

See original GitHub issue

Hi there, Thank you very much for maintaining this repo. I tried to build it on my GNU/Linux Debian 10 system. I have node v10.23.0 and yard 1.22.10 version. I received the following error after running the Quick Start instruction gatsby new my-map-app Looks like an eslint dependency issue.

info Creating new site from git:

Cloning into 'my-map-app'...
remote: Enumerating objects: 89, done.
remote: Counting objects: 100% (89/89), done.
remote: Compressing objects: 100% (74/74), done.
remote: Total 89 (delta 1), reused 52 (delta 1), pack-reused 0
success Created starter directory layout
info Installing packages...

npm ERR! code ERESOLVE
npm ERR! ERESOLVE unable to resolve dependency tree
npm ERR! 
npm ERR! While resolving: gatsby-starter-leaflet@0.3.0
npm ERR! Found: eslint@7.20.0
npm ERR! node_modules/eslint
npm ERR!   dev eslint@"^7.20.0" from the root project
npm ERR! 
npm ERR! Could not resolve dependency:
npm ERR! peer eslint@"^6.5.1" from eslint-config-zurgbot@0.1.0
npm ERR! node_modules/eslint-config-zurgbot
npm ERR!   dev eslint-config-zurgbot@"^0.1.0" from the root project
npm ERR! 
npm ERR! Fix the upstream dependency conflict, or retry
npm ERR! this command with --force, or --legacy-peer-deps
npm ERR! to accept an incorrect (and potentially broken) dependency resolution.
npm ERR! 
npm ERR! See /home/user/.npm/eresolve-report.txt for a full report.

npm ERR! A complete log of this run can be found in:


Command failed with exit code 1: npm install

  Error: Command failed with exit code 1: npm install
  - error.js:56 makeError
  - index.js:114 handlePromise
  - next_tick.js:68 process._tickCallback

Then, I headed for the Starting from Scratch approach. I ran the instruction yarn global add gatsby-cli. After that I also checked the Gatsby version: Gatsby CLI version: 2.19.1. After running the instruction gatsby new my-map-app I ended up with the same error as in the Quick Start approach. Sadly, I am not able to move forward to run yarn develop.

Is anyone familiar with this issue and does not mind to point me in the right direction?

Cheers, Stefan

Issue Analytics

  • State:closed
  • Created 3 years ago
  • Reactions:1
  • Comments:7 (3 by maintainers)

github_iconTop GitHub Comments

bierophagecommented, Mar 2, 2021

Hi! I had the same issue as dancesWithCycles with npm, “yarn install” did the job

colbyfayockcommented, Feb 28, 2021

@dancesWithCycles inside of the project, try:

yarn remove gatsby-plugin-manifest

then open up the file gatsby-config.js and remove the item from the plugins array with the same name

Read more comments on GitHub >

github_iconTop Results From Across the Web

Could not resolve dependency: peer eslint@"^5.0.0 - GitHub
Prerequisites I am running the latest version I checked the documentation and found no answer I checked to make sure that this issue...
Read more >
Unable to resolve dependency tree with eslint-config-airbnb
Run npm install --legacy-peer-deps and they will install successfully. Looking at your package. json and comparing it to the peer dependencies ...
Read more >
npm err! code eresolve npm err! eresolve could not resolve ...
It means you have dependency conflicts. So try running the following options one by one. 1. Remove node_modules and package-lock.json and then run....
Read more >
How to Fix npm ERR ERESOLVE Unable to Resolve ...
Command:- npm config set legacy-peer-deps trueIn This Video We Will See How to Fix npm ERR ERESOLVE Unable to Resolve Dependency Tree ...
Read more >
eslint - npm
Why can't ESLint find my plugins? · Make sure your plugins (and ESLint) are both in your project's package. · Make sure you...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found