Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Mounting audio CDs

See original GitHub issue

Issue Description


Is there a way to mount CD-ROMs with udiskie?

I tried udiskie-mount /dev/sr0 but the error message said it was an unhandled device.

Issue Analytics

  • State:closed
  • Created 3 years ago
  • Comments:9 (9 by maintainers)

github_iconTop GitHub Comments

coldfixcommented, Feb 2, 2020


I’m no expert in these things, but from google research it’s not possible to mount audio CDs.

This also agrees with the fact that udisksctl dump doesn’t list a org.freedesktop.UDisks2.Filesystem interface for the CD.

Should you happen find that there are indeed drivers that allow exposing the audio tracks as a filesystem, please let me know here (for my curiosity and future readers).

I’m closing this for now since you say that normal data CDs work.

Best, Thomas

coldfixcommented, Jan 30, 2020


thanks for the output! Looks like the device for the CD drive is not properly handled by the cases in Mounter.add. I put this on my TODO for the next release, but I can’t promise making it timely, I’m afraid.

Best, Thomas

Read more comments on GitHub >

github_iconTop Results From Across the Web

[SOLVED] How to mount audio cd manually
Hello, I would like to ask you how to mount audio cds in linux manually. Normally, when I insert disk into cd-rom, Gnome...
Read more >
”Mounting” an audio CD in a Linux terminal or in a Bash script
It seems like it needs to be ”mounted” first. I know that an audio CD doesn't have a file system and isn't really...
Read more >
How can I create a mountable Audio CD image?
My idea is to create an Audio CD image that I can mount without any third-party software in Windows 10, then to compress...
Read more >
mount - Audio cd doesn't play - Unix & Linux Stack Exchange
Failed to mount "Audio CD". Location is not mountable. I've been searching since yesterday but as I see there is a general problem...
Read more >
Problem trying to mount image file (iso) from an audio CD.
I can mount any other iso files (video DVDs, software), but music cds. This is what happens: That's the message I'm getting, but...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found