Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

package:windows fails

See original GitHub issue

Issue Description

  • I’m submitting a … [ * ] bug report [ ] feature request [ ] question about the decisions made in the repository

  • What is the current behavior? npm run package:windows fails with Exit status 4294967295

  • Please tell us about your environment: i ran the latest source codes of angular-electron-dream-starter@7.0.0 without any changes

npm install -> npm build:prod -> npm run launch -> npm run packages:windows -> failed

Attached debug log

0 info it worked if it ends with ok
1 verbose cli [ 'C:\\Program Files\\nodejs\\node.exe',
1 verbose cli   'C:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js',
1 verbose cli   'run',
1 verbose cli   'package:windows' ]
2 info using npm@5.3.0
3 info using node@v8.5.0
4 verbose run-script [ 'prepackage:windows',
4 verbose run-script   'package:windows',
4 verbose run-script   'postpackage:windows' ]
5 info lifecycle angular-electron-dream-starter@7.0.0~prepackage:windows: angular-electron-dream-starter@7.0.0
6 info lifecycle angular-electron-dream-starter@7.0.0~package:windows: angular-electron-dream-starter@7.0.0
7 verbose lifecycle angular-electron-dream-starter@7.0.0~package:windows: unsafe-perm in lifecycle true
8 verbose lifecycle angular-electron-dream-starter@7.0.0~package:windows: PATH: C:\Program Files\nodejs\node_modules\npm\bin\node-gyp-bin;C:\Users\lx\Downloads\angular-electron-dream-starter\node_modules\.bin;C:\ProgramData\Oracle\Java\javapath;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\WebEx\Productivity Tools;C:\Program Files\Microsoft SQL Server\130\Tools\Binn\;C:\Program Files\dotnet\;C:\Program Files\Git\cmd;C:\Program Files (x86)\GtkSharp\2.12\bin;C:\Program Files\IVI Foundation\VISA\Win64\bin;C:\Program Files (x86)\IVI Foundation\VISA\WinNT\ktvisa;C:\Program Files (x86)\IVI Foundation\VISA\WinNT\bin;C:\Program Files (x86)\IVI Foundation\IVI\bin;C:\Program Files\IVI Foundation\IVI\bin;C:\Program Files (x86)\IVI Foundation\VISA\WinNT\Bin\;C:\Program Files\IVI Foundation\VISA\Win64\Bin\;C:\Program Files (x86)\IVI Foundation\VISA\winnt\agvisa;C:\Program Files (x86)\MATLAB\MATLAB Compiler Runtime\v716\runtime\win32;C:\WINDOWS\system32\config\systemprofile\.dnx\bin;C:\Program Files\Microsoft DNX\Dnvm\;C:\Program Files\Microsoft SQL Server\110\Tools\Binn\;C:\Program Files (x86)\WebEx\PTools020000000;C:\Program Files (x86)\Sennheiser\SoftphoneSDK\;C:\Program Files\nodejs\;C:\Users\louislow\AppData\Local\Microsoft\WindowsApps;C:\Users\lx\AppData\Local\atom\bin;C:\Program Files (x86)\Microsoft VS Code\bin;C:\Users\lx\AppData\Roaming\npm
9 verbose lifecycle angular-electron-dream-starter@7.0.0~package:windows: CWD: C:\Users\lx\Downloads\angular-electron-dream-starter
10 silly lifecycle angular-electron-dream-starter@7.0.0~package:windows: Args: [ '/d /s /c', 'rimraf packages/win/* && build --win --x64' ]
11 silly lifecycle angular-electron-dream-starter@7.0.0~package:windows: Returned: code: 4294967295  signal: null
12 info lifecycle angular-electron-dream-starter@7.0.0~package:windows: Failed to exec package:windows script
13 verbose stack Error: angular-electron-dream-starter@7.0.0 package:windows: `rimraf packages/win/* && build --win --x64`
13 verbose stack Exit status 4294967295
13 verbose stack     at EventEmitter.<anonymous> (C:\Program Files\nodejs\node_modules\npm\lib\utils\lifecycle.js:289:16)
13 verbose stack     at emitTwo (events.js:125:13)
13 verbose stack     at EventEmitter.emit (events.js:213:7)
13 verbose stack     at ChildProcess.<anonymous> (C:\Program Files\nodejs\node_modules\npm\lib\utils\spawn.js:40:14)
13 verbose stack     at emitTwo (events.js:125:13)
13 verbose stack     at ChildProcess.emit (events.js:213:7)
13 verbose stack     at maybeClose (internal/child_process.js:927:16)
13 verbose stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:211:5)
14 verbose pkgid angular-electron-dream-starter@7.0.0
15 verbose cwd C:\Users\lx\Downloads\angular-electron-dream-starter
16 verbose Windows_NT 10.0.14393
17 verbose argv "C:\\Program Files\\nodejs\\node.exe" "C:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "run" "package:windows"
18 verbose node v8.5.0
19 verbose npm  v5.3.0
20 error code ELIFECYCLE
21 error errno 4294967295
22 error angular-electron-dream-starter@7.0.0 package:windows: `rimraf packages/win/* && build --win --x64`
22 error Exit status 4294967295
23 error Failed at the angular-electron-dream-starter@7.0.0 package:windows script.
23 error This is probably not a problem with npm. There is likely additional logging output above.
24 verbose exit [ 4294967295, true ]

Issue Analytics

  • State:closed
  • Created 5 years ago
  • Comments:13 (4 by maintainers)

github_iconTop GitHub Comments

rdafoecommented, Oct 4, 2017

Hi Colin,

First off. Great job man, thanks so much for creating this!!!

Had same issue as @celestale on a surface pro 3 up-to-date. Stopped after first failure on package creation, then tried dev/prod/aot builds same failure basically.

Tried your suggestion to npm clean and reinstall. This fixed everything: builds, packages, tests, etc.

Kaffiendcommented, Sep 27, 2017

@celestale sure its simple. npm i -g rimraf any powershell or windows cmd instances you have open close them and reopen, node by default should add a global flagged install to path. But you may need to run CMD or Powershell as Administrator when you run the install command.

This usually installs to C:\Users\UserNameHere\AppData\Roaming\npm but i have seen packages install to C:\Users\UserNameHere\npm as well. to add to path if either are not there already just run SETX /M PATH "%PATH%;C:\Users\UserNameHere\AppData\Roaming\npm or what ever path you need in place of the path after ; in the command the /M switch makes it a system level entry to the PATH variable which is in turn run at system level permissions

Read more comments on GitHub >

github_iconTop Results From Across the Web

Fixed: “There is a problem with this Windows installer package ...
Fixed “There is a problem with this Windows installer package” · Method 1: Make sure you have administrative permissions · Method 2: Use...
Read more >
How to troubleshoot Windows Installer errors - Microsoft Support
Right-click Windows Installer, and then click Properties. If the Startup type box is set to Disabled, change it to Manual. Click OK to...
Read more >
How to Fix Issues With the Windows Installer Package
1. Restart Your PC · 2. Run the File as an Administrator · 3. Run Program Install and Uninstall Troubleshooter · 4. Restart...
Read more >
There is a problem with this Windows installer package Fix
There is a problem with this Windows installer package Fix · Fix 1: Tweak the Registry Settings · Fix 2 – Change Temp...
Read more >
How to Fix The 'Problem With This Windows Installer Package ...
How to Fix a Problem With Windows Installer Package · Restart the computer. Restarting Windows can fix a variety of problems, including Windows...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found