Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

loadOptions doesn't seems to work

See original GitHub issue


Just called loadOptions with new params then getDevice(). Nothing happens. I saw this issue which supposedly worked.

Steps to reproduce

  1. Created a videojs with:
const videoJsOptions = {
                controls: false,
                width: 320,
                height: 480,
                // frameWidth: screen.width,
                // frameHeight: screen.height * .8,
                fluid: true,
                plugins: {
                    record: {
                        // audio: true,
                        // video: true,
                        image: {
                            facingMode: 'user'
                        // maxLength: 10,
                        debug: true,
  1. a click event:
const onClickChangeCamera = () =>
        // setCurrentCamera(cameras.find(camera => camera.deviceId !== currentCamera.deviceId));
        // player.record().setVideoInput(currentCamera.deviceId);
                image: {
                    facingMode: 'environment',

As you see, I also tried with setVideoInput and nothing happened too.



Swap cameras.


Nothing happens.

Error output

No errors.

Additional Information

Please include any additional information necessary here. Including the following:



"video.js": "^7.6.0",
"videojs-record": "^3.8.0"


  • Chrome 76.0.3809.132, Android 8.0 Samsung Galaxy S7

I don’t have any other device with 2 cameras for test =/

Issue Analytics

  • State:closed
  • Created 4 years ago
  • Comments:10 (8 by maintainers)

github_iconTop GitHub Comments

naveedabbascommented, Nov 29, 2019

@vendramini any luck? I am trying on my end as well. Please keep updated

vendraminicommented, Nov 25, 2019

@thijstriemstra I’ll back here and to my PR this week or next. Lasts 2 months was insane, sorry.

Read more comments on GitHub >

github_iconTop Results From Across the Web

react select load async options does not load - Stack Overflow
The issue you're experiencing seems to be due to the fact that you're not returning anything at the top-level of the loadOptions function....
Read more >
Assembly Load options - "as saved" ELSE "from folder" ?
Working in a Native (non TC) environment, with network folders - Is there a way to open an assembly using "As saved", BUT...
Read more >
Async - React Select
Use the Async component to load options from a remote source as the user types. ... The loadOptions prop allows users to either...
Read more >
dxDataGrid - Cannot get Un/SelectAll to work with CustomStore
The loadOptions object doesn't contain the skip and take parameters (they are undefined) if the "Select All" checkbox is clicked. So, you're ...
Read more >
How to debug custom node during development? - Questions
ts to dynamically load options in the node. But it doesn't work at all. How to go about debugging this? Usually, i would...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found