Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

[BUG]: Unable to build the 0.4.0 package using setuptools

See original GitHub issue


Unable to build the 0.4.0 colour package using setuptools (this is for packaging for the msys2 repo). Previous 0.3.16 version built fine.

Code for Reproduction

`python build`

Exception Message

`error in colour-science setup command: 'extras_require' must be a dictionary whose values are strings or lists of strings containing valid project/version requirement specifiers.`

Environment Information

MSYS2 (MinGW-w64) Python 3.9.10 w/ setuptools 59.8.0

Issue Analytics

  • State:closed
  • Created 2 years ago
  • Comments:10 (5 by maintainers)

github_iconTop GitHub Comments

kmiloscommented, Feb 23, 2022


FYI, I have also tried w/ newer setuptools 60.9.3 in a conda environment, and it throws the exact same error.

KelSolaarcommented, Feb 22, 2022

Thanks for confirming, I will release a new version if not tomorrow, this weekend!

Read more comments on GitHub >

github_iconTop Results From Across the Web

Build error with the latest setuptool #4539 - onnx/onnx - GitHub
Describe the bug. Building from source with pip install -e . resulted in an error with the latest setuptool. Running. SETUPTOOLS_ENABLE_FEATURES ...
Read more >
Installation of a python package vsm not working
Hi, I have a problem when I try to install a python package for doing NLP named vsm in the environment section of...
Read more >
Bug listing with status CONFIRMED as at 2022/12/20 18:46:38
Stream audio to icecast from python." status:CONFIRMED resolution: severity:normal · Bug:47670 - "sci-mathematics/gambit- (New Package)" ...
Read more >
#60474 (py-spaCy @2.2.4: the `allow-hosts` option is not ...
Installation of py38-spaCy fails, because py38-spaCy-2.2.4_0.darwin_19.x86_64.tbz2 is not available from ​ (and ...
Read more >
I can't install TensorFlow-macos a… | Apple Developer Forums
pip install tensorflow-macos , is failing with below error ... (6.7 kB) Using legacy ' install' for numpy, since package 'wheel' is not...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found