Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

[0.14.0] Problem with React-Native

See original GitHub issue

The new version 0.14.0 works great on web, but when I tried to upgrade my react-native app it failed. I downgraded my server and app back to 0.13.2 and it was working again.

this is the error log:

TypeError: _1.registerType is not a function. (In '_1.registerType("array", {
    constructor: ArraySchema,
    getProxy: getArrayProxy
  })', '_1.registerType' is undefined)
* /Users/bjoern/projects/arithmeticgame/node_modules/react-native/Libraries/LogBox/LogBox.js:148:8 in registerError
* /Users/bjoern/projects/arithmeticgame/node_modules/react-native/Libraries/LogBox/LogBox.js:59:8 in errorImpl
* /Users/bjoern/projects/arithmeticgame/node_modules/react-native/Libraries/LogBox/LogBox.js:33:4 in console.error
* /Users/bjoern/projects/arithmeticgame/node_modules/expo/build/environment/react-native-logs.fx.js:27:4 in error
* /Users/bjoern/projects/arithmeticgame/node_modules/react-native/Libraries/Core/ExceptionsManager.js:104:6 in reportException
* /Users/bjoern/projects/arithmeticgame/node_modules/react-native/Libraries/Core/ExceptionsManager.js:171:19 in handleException
* /Users/bjoern/projects/arithmeticgame/node_modules/react-native/Libraries/Core/setUpErrorHandling.js:24:6 in handleError
* /Users/bjoern/projects/arithmeticgame/node_modules/expo-error-recovery/build/ErrorRecovery.fx.js:9:32 in ErrorUtils.setGlobalHandler$argument_0
* /Users/bjoern/projects/arithmeticgame/node_modules/regenerator-runtime/runtime.js:63:36 in tryCatch
* /Users/bjoern/projects/arithmeticgame/node_modules/regenerator-runtime/runtime.js:293:29 in invoke
* /Users/bjoern/projects/arithmeticgame/node_modules/regenerator-runtime/runtime.js:63:36 in tryCatch
* /Users/bjoern/projects/arithmeticgame/node_modules/regenerator-runtime/runtime.js:154:27 in invoke
* /Users/bjoern/projects/arithmeticgame/node_modules/regenerator-runtime/runtime.js:164:18 in PromiseImpl.resolve.then$argument_0
* /Users/bjoern/projects/arithmeticgame/node_modules/react-native/node_modules/promise/setimmediate/core.js:37:13 in tryCallOne
* /Users/bjoern/projects/arithmeticgame/node_modules/react-native/node_modules/promise/setimmediate/core.js:123:24 in setImmediate$argument_0
* /Users/bjoern/projects/arithmeticgame/node_modules/react-native/Libraries/Core/Timers/JSTimers.js:130:14 in _callTimer
* /Users/bjoern/projects/arithmeticgame/node_modules/react-native/Libraries/Core/Timers/JSTimers.js:181:14 in _callImmediatesPass
* /Users/bjoern/projects/arithmeticgame/node_modules/react-native/Libraries/Core/Timers/JSTimers.js:441:30 in callImmediates
* /Users/bjoern/projects/arithmeticgame/node_modules/react-native/Libraries/BatchedBridge/MessageQueue.js:387:6 in __callImmediates
* /Users/bjoern/projects/arithmeticgame/node_modules/react-native/Libraries/BatchedBridge/MessageQueue.js:135:6 in __guard$argument_0
* /Users/bjoern/projects/arithmeticgame/node_modules/react-native/Libraries/BatchedBridge/MessageQueue.js:364:10 in __guard
* /Users/bjoern/projects/arithmeticgame/node_modules/react-native/Libraries/BatchedBridge/MessageQueue.js:134:4 in flushedQueue
* [native code]:null in flushedQueue
* [native code]:null in invokeCallbackAndReturnFlushedQueue

Issue Analytics

  • State:closed
  • Created 3 years ago
  • Comments:6 (2 by maintainers)

github_iconTop GitHub Comments

serjekcommented, Nov 16, 2020

Hello @BjoernRave I would recommend first to set up a clean project and try to get it reproduced there. From what I can see there is something wrong with schema bindings. Also try to remove node_modules and package.lock and npm i again. I use RN 63.3 + colyseus haxe and it is working fine (except wss ping-pong handling on RN side)

BjoernRavecommented, Nov 24, 2020

Yes, now it works.

Thank you very much for responding so quick. Appreciate your work on this project. It has been a pleasure working with it so far 😃

Read more comments on GitHub >

github_iconTop Results From Across the Web

npm WARN react-native-maps@0.14.0 requires a peer of ...
Here's how I was able to solve this (chronological order):. Deleted node_module directory from the project; npm cache clean ...
Read more >
npm WARN react-native-maps@0.14.0 requires a peer of ...
Problem I'm trying to install react-native-maps by Airbnb in my project. Installation instructions: airbnb/react-native-maps/installation.
Read more >
React v0.14 – React Blog
We have two new small breaking changes that didn't give a warning in 0.13 (see below). Every new change in 0.14, including the...
Read more >
react-native-web - npm
React Native for Web. Latest version: 0.18.10, last published: 2 months ago. Start using react-native-web in your project by running `npm i ...
Read more >
Downloads | React
The uncompressed, development version of react.js and react-dom.js with inline documentation (you need both files). <script src=" ...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found