Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Enable "conda install COMPAS" to work on Apple Silicon M1 Macs

See original GitHub issue

Feature Request

As an M1 mac user, it would be fantastic to be able to follow the suggested installation for compas without errors. Maybe it’s as easy as adding a respective image to the conda-forge/osx-arm64 channel.


When trying to install compas with the regular (mini)conda setup I get the error message that the compas package is not available in any of the channels, even after running conda config --add channels conda-forge (as expected since it is not in the ARM channel). I then tried to install the package via pip, which somewhat worked but only installed version 0.3.9.

The best workaround I could find was to set up conda in rosetta/intel-virtualization mode following these instructions on a miniforge fork:

CONDA_SUBDIR=osx-64 conda create -n [environment]   # create a new environment
conda activate [environment]
conda env config vars set CONDA_SUBDIR=osx-64  # subsequent commands use intel packages

In that environment, the installation went as expected and I got the latest version. However, this of course runs all packages using the Intel versions which might impair performance.

Issue Analytics

  • State:closed
  • Created 2 years ago
  • Reactions:1
  • Comments:5 (3 by maintainers)

github_iconTop GitHub Comments

brgcodecommented, Jan 22, 2022

as far as i can tell, we are supposed to send a PR to the conda-forge-pinning feedstock to add support for osx_arm64 to compas.

i just did that. see here i also tried the manual version but it failed.

i guess now we have to wait 😃

irruputuncucommented, Feb 3, 2022

Yes! It is seamlessly installed from the ARM channels now and I can also confirm that python runs in Apple Silicon mode now.

Thanks a lot!

Read more comments on GitHub >

github_iconTop Results From Across the Web

How to Manage Conda Environments on an Apple Silicon M1 ...
To activate the conda environment, run conda activate myenv (you can view a list of all of your conda environments with conda env...
Read more >
Use Mambaforge to Conda Install PyData Stack on your Apple ...
Running PyData libraries on an Apple M1 machine requires you to use an ARM64-tailored version of conda-forge. This article provides a step-by- ...
Read more >
- Installation - COMPAS
The recommended way to install COMPAS is with conda. For example, create an environment named research and install COMPAS. conda config --add channels...
Read more >
Anaconda on the new Macs with M1 chip - YouTube
In this video, we install and test Anaconda with the new Macs with the M1 chip.The simulation test was run using this code: ......
Read more >
Conda on M1 Mac with Miniforge - Ryan
Once it's done you're ready to use Homebrew. Install Miniforge. With Homebrew installed, open terminal and type: brew install miniforge. After ...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found