Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Python3 doesn't work on OSX

See original GitHub issue

Traceback (most recent call last):
  File "/Users/travis/.pyenv/versions/3.6.1/envs/conan/lib/python3.6/site-packages/pkg_resources/", line 659, in _build_master
  File "/Users/travis/.pyenv/versions/3.6.1/envs/conan/lib/python3.6/site-packages/pkg_resources/", line 967, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/Users/travis/.pyenv/versions/3.6.1/envs/conan/lib/python3.6/site-packages/pkg_resources/", line 858, in resolve
    raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.ContextualVersionConflict: (pyOpenSSL 17.0.0 (/Users/travis/.pyenv/versions/3.6.1/envs/conan/lib/python3.6/site-packages), Requirement.parse('pyOpenSSL<16.1.0,>=16.0.0'), {'conan'})

Tested it failing for Python 3.5 and 3.6.

In Linux it works fine.

Issue Analytics

  • State:closed
  • Created 6 years ago
  • Comments:12 (11 by maintainers)

github_iconTop GitHub Comments

theodelrieucommented, Nov 16, 2017


I have an issue with Python 3.6 on macOS too, the following code builder = ConanMultiPackager() fails with:

>Traceback (most recent call last): File “”, line 19, in <module> builder = ConanMultiPackager() File “/Users/theo/Library/Python/3.6/lib/python/site-packages/conan/”, line 217, in init _, client_cache, _ = Conan.factory() TypeError: ‘ConanAPIV1’ object is not iterable

Python 2.7 works fine, and everything works on Linux/Windows.

Nevermind, forgot the pip3 --upgrade flag 😄

nunojpgcommented, Jun 1, 2017

Tested. Your commit fixes it.

BTW, problem also breaks OSX builds with Python 2.7 since TODAY. For example this repo Travis CI is failing for OSX because of that.

So this should be released on conan when possible to resume OSX builds.

Read more comments on GitHub >

github_iconTop Results From Across the Web

Mac Python3 Not Working, any idea? - Stack Overflow
I went to the ~/.bash_profile to add "alias python='python3'" when I noticed there was another export PATH to python3. Upon removing that ...
Read more >
Installing Python 3 on Mac OS X
You do not need to install or configure anything else to use Python 2. ... To install Homebrew, open Terminal or your favorite...
Read more >
Python not working on Mac OS M1 as… - Apple Developer
Python not working on Mac OS M1 asking to install cmd developer tools ... Then, ask to install the command developer tools. I...
Read more >
How to install the latest Python 3 on Mac with no issues
I tried several approaches to installing Python 3 on Mac, and this is what worked as the best solution for these three goals:...
Read more >
The right and wrong way to set Python 3 as default on a Mac
Use Python 3 as the macOS default​​ Python's website has a macOS Python 3 installer we can download and use. If we use...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found