Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Getting error on miniconda conda-incubator/setup-miniconda@v2.1.1 with no base environment activated

See original GitHub issue

Using the below yaml:

name: QA - Precommit Checks
on: [push]
    runs-on: self-hosted
      - run: echo "Checking branch precommit hooks ..."
      - run: echo "Now running on a ${{ runner.os }} server ..."
      - run: echo "The name of your branch is ${{ github.ref }} ..."
      - name: Check out repository code
        uses: actions/checkout@v2
      - name: Setup Miniconda
        uses: conda-incubator/setup-miniconda@v2.1.1
          activate-environment: sigma-sealevel
          environment-file: environment.yml
          python-version: 3.10
          auto-activate-base: false
      - run: |
          pre-commit run --all-files

I get a very strange error at Setup Miniconda with

Run conda-incubator/setup-miniconda@v2.1.1
Gathering Inputs...
Creating bootstrap condarc file in /home/ubuntu/.condarc...
Ensuring installer...
Error: No installed conda 'base' enviroment found at 

Even with the enviroment typo, not sure what that is about, some guidance would be appreciated!! Thank you

Issue Analytics

  • State:open
  • Created 2 years ago
  • Reactions:4
  • Comments:10 (3 by maintainers)

github_iconTop GitHub Comments

czyzi0commented, Mar 14, 2022

Hi, I’ve encountered identical error but when I’ve specified particular url of installer to use with installer-url parameter it seemed to work ok. I don’t know why default setting does not work but this may be a temporary workaround.

casperdclcommented, Sep 9, 2022

The URL version fails when you restart a job (it tries to re-download miniconda and somehow gets confused).

This worked for me:

    - uses: conda-incubator/setup-miniconda@v2
        environment-file: ...
        activate-environment: ...
        python-version: ...
        miniconda-version: latest
        auto-activate-base: false
    - shell: bash --login {0}
      run: ...
Read more comments on GitHub >

github_iconTop Results From Across the Web

NoBaseEnvironmentError · Issue #8930 · conda ... - GitHub
I am trying to update conda by running conda update conda but get the error: NoBaseEnvironmentError: This conda installation has no default base...
Read more >
Anaconda won't update: "No default base environment" error
I've been trying to update my Anaconda installation, but whether I run the updater from the GUI or the Terminal via conda update...
Read more >
Troubleshooting — conda 22.11.1.post17+e3a05b6f5 ...
Conda upgrade error. ValidationError: Invalid value for timestamp. Unicode error after installing Python 2. Windows environment has not been activated.
Read more >
Manage your Python Virtual Environment with Conda
We can use conda env list to list all existing Python environments. The * will point to the current active environment. base is...
Read more >
CondaInstall - GNU Radio Wiki
8.2 Why do I get cryptic error messages with a new GNU Radio installation ... From a console with the base conda environment...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found