Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

GitHub Action stuck @ creating conda environment

See original GitHub issue

Great Action! We use it in our research 😊💻 However, there is an issue: Inside our CI workflow here we have:

      - name: Setup miniconda & zarp root env
        uses: conda-incubator/setup-miniconda@v2
          python-version: 3.7.4
          miniconda-version: 4.7.12
          auto-update-conda: false
          environment-file: install/environment.root.yml
          activate-environment: zarp
          auto-activate-base: false

This step often gets stuck (seemingly forever) and the whole workflow needs to be restarted. Then it passes. Strange…

Issue Analytics

  • State:open
  • Created 2 years ago
  • Reactions:1
  • Comments:8 (5 by maintainers)

github_iconTop GitHub Comments

goanpecacommented, Sep 21, 2021

But I restarted it, so now it passed.

If you could start a. “test” PR and see it happen, it would make it easier to take a look 😃

AngryMaciekcommented, Oct 12, 2021

Dear @goanpeca, I have removed the fixed miniconda version (so I assume that it always pulls the latest) but the problem still persists…

Read more comments on GitHub >

github_iconTop Results From Across the Web

Creating miniconda environment gets stuck on "Solving ...
I fetched a repository from work that needs miniconda, I use it daily on Ubuntu. I often move around machines and never had...
Read more >
Creating a conda environment is taking a long time #2132
Conda environment installation of the tool can take time but not several hours. You could try stopping, removing any partially created ...
Read more >
Conda hangs on solving environment · Issue #8197 - GitHub
The problem appears to be new. I first encountered it several days ago when trying to create a new environment containing the phyloflash...
Read more >
Conda stuck solving environment when installing v1.5 #410
I have the problem you are mentioning, that conda gets stuck while solving the environment. I then tried using mamba as you suggested...
Read more >
can't install anything using conda, it hangs in solving ... - GitHub
It hangs in "solving environment". I tried: conda install -c anaconda pip conda install conda-build conda update conda conda install c- anaconda ......
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found