Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Problems when creating a new env

See original GitHub issue

Issue Description

Hi, @goanpeca!

First of all, congratulations for this action! And thanks for providing it!

Well, unfortunately, I have been facing a problem in Windows builds with your GH actions. I use conda-devenv to build conda environments in a development mode. It provides extended capabilities when compared with regular conda, I can define environment variables, use jinja2 and etc.

The problem is: when I do my tests, I create a new environment using conda devenv. For reason unknown, when I use your Action, the created environment receive an empty name.

Below I provide my windows build file:

name: windows

      - master


    - cron: "0 5 * * 1"  # runs at 05:00 UTC on Mondays


    runs-on: windows-latest
      configuration: Release
      fail-fast: true
      max-parallel: 4

    - uses: actions/checkout@v1
    - uses: goanpeca/setup-miniconda@v1.0.2
        auto-update-conda: true
        activate-environment: autodiff
    - name: Install conda-devenv
      shell: powershell
      run: |
        conda install -c conda-forge conda-devenv
        conda info -a
    - name: Build
      shell: powershell
      run: |
        conda devenv
        conda info --envs
        conda activate autodiff
        cmake -S . -B build
        cmake --build build --config ${{ env.configuration }} --target install
    - name: Tests
      shell: powershell
      run: call build\test\${{ env.configuration }}\tests.exe

I even tried to put the same name of my new environment as activate-environment, since conda-devenv can re-generate an env on an existing env without problem. However, when I do it, the new env is created without a name. When I run conda info --envs in the CI (windows only), I get the following output:

2020-01-29T22:35:24.9862529Z # conda environments:
2020-01-29T22:35:24.9863192Z #
2020-01-29T22:35:24.9863428Z base                     C:\Miniconda
2020-01-29T22:35:24.9863652Z autodiff              *  C:\Miniconda\envs\autodiff
2020-01-29T22:35:24.9863862Z                          C:\Miniconda\envs\autodiff\envs\autodiff

Do you know how I could solve such problem?


Issue Analytics

  • State:closed
  • Created 3 years ago
  • Comments:12 (5 by maintainers)

github_iconTop GitHub Comments

volpattocommented, Jan 31, 2020

I talked with one of conda-devenv maintainers, the conclusion was unclear. But definitely it isn’t a problem related to the GH Action side.

volpattocommented, Jan 30, 2020

To be honest, I don’t know if this is a conda-devenv issue (probably it is). I will check it tomorrow with the maintainers (actually they work in a room in front of mine, so it’s easy for me). It’s more like to be a problem at conda-devenv side. I think that the Action is fine. When I created an env with conda create -n foo, it works properly, creating the env at C:\Miniconda\envs\foo.

Well, I will check conda-devenv tomorrow in order to improve it there.

Thanks for helping me out, @goanpeca


Read more comments on GitHub >

github_iconTop Results From Across the Web

Problems with creating new environment with Anaconda
I wanted to recreate my env with the packages that i need to use for a project. So I broswered in the Anaconda...
Read more >
20 Current Environmental Problems That Our World is Facing
20 Major Current Environmental Problems · 1. Pollution · 2. Soil Degradation · 3. Global Warming · 4. Overpopulation · 5. Natural Resource...
Read more >
Conda env create fails using environment.yml file. · Issue #9480
I exported an environment using conda env export > environment.yml. I installed miniconda3 on a different system, updated conda, ...
Read more >
Solved: Unable to Create New Prod Env: "At least 1GB capac...
Solved: I'm the GA for my tenant. Never had an issue creating environments before today. Only able to create Trial environment. Each time...
Read more >
The Triumph and Tragedy of .env Files - Doppler
They helped us in the past, but .env files are simply too risky and cumbersome for modern application development.
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found