Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Including icon Fails with "could not find attachment"

See original GitHub issue

Issue Description

When attempting to publish a file that contained as csv file I had errors due to the attachment not found. I’m running through docker, only way it succeeded was when I stopped including the csv file as include and pasted it in directly into the table contents.

CSV Format looked like

"Team","Member or Group"
"Team1","icon:user[] BurritoBoy"
"Team1","icon:user[] TacoMan"

I tried to ensure it had underscores in the name, but it still failed, I’ve also tried adjusting with ./_file and include::_file to ensure path issues weren’t the problem.

[caption="Response Team "]

Exception in thread "main" java.lang.RuntimeException: Could not find attachment 
        at org.sahli.asciidoc.confluence.publisher.client.ConfluencePublisher.fileInputStream(
        at org.sahli.asciidoc.confluence.publisher.client.ConfluencePublisher.addOrUpdateAttachment(
        at org.sahli.asciidoc.confluence.publisher.client.ConfluencePublisher.lambda$addAttachments$9(
        at java.util.HashMap.forEach(
        at org.sahli.asciidoc.confluence.publisher.client.ConfluencePublisher.addAttachments(
        at org.sahli.asciidoc.confluence.publisher.client.ConfluencePublisher.lambda$startPublishingUnderAncestorId$1(
        at java.util.ArrayList.forEach(
        at org.sahli.asciidoc.confluence.publisher.client.ConfluencePublisher.startPublishingUnderAncestorId(
        at org.sahli.asciidoc.confluence.publisher.client.ConfluencePublisher.publish(
        at org.sahli.asciidoc.confluence.publisher.cli.AsciidocConfluencePublisherCommandLineClient.main(
Caused by: /tmp/confluence-publisher1621229107102861561/assets/3f70f6e9d48eba115943f9083b309afbdedcb9b30c285b6e472c765f760fd28e/user (No such file or directory)
        at Method)
        at org.sahli.a

Issue Analytics

  • State:open
  • Created 3 years ago
  • Reactions:1
  • Comments:6 (2 by maintainers)

github_iconTop GitHub Comments

cstettlercommented, Feb 12, 2020

Hi @sheldonhull, thank your for your issue. Icons are currently not yet supported by the Confluence Publisher. Unfortunately, the renderer is not distinguishing between an icon and an image and therefore renders an attachment link for icons, too. Subsequently, the upload fails as the attachment does not exist as a file.

I will have a look into it asap to see how to at least ignore icon directives so that the publishing does no longer fail (but then will ignore the icon). Do you want to open a feature request for actually supporting icons? Not sure though whether that would be feasible within Confluence.

cstettlercommented, Nov 1, 2022

Hi @Riduidel, thank you for your support, a pull request would be highly appreciated. At least me, I am not currently working on this. Thank you!

Read more comments on GitHub >

github_iconTop Results From Across the Web

Outlook attachment icon problem
If the message doesn't contain an attachment and the issue is caused by a View corruption, then View-> reset View is likely to...
Read more >
How to Fix It When Attachments Aren't Showing in Outlook
Try these tips to solve the problem of receiving an Outlook email that should have an attachment, but it's not showing.
Read more >
all of the sudden, my attachment icon does nothing. Can't ...
all of the sudden, my attachment icon does nothing. Can't attach a file. No error message. clicked on the paperclip icon several times....
Read more >
The attachment icon next to the name does not reflect ...
The attachment icon next to the name does not reflect the file content-type when attaching a file without an extension. 225 Views I...
Read more >
c# - Emails do not display the paperclip icon even though ...
I don't even know how to define a google search for this problem since I can't avoid using very highly used words like...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found