Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Command [/usr/local/bin/dub path /var/lib/kafka/data writable] FAILED !

See original GitHub issue

I’m using kafka image v6.1.4-2-ubi8 pulled from

Building my own Docker using above and using it in a kubernetes pod

While trying to run the image, I am getting the mentioned error

===> User
uid=1000670000(1000670000) gid=0(root) groups=0(root),1000670000
===> Configuring ...
SSL is enabled.
===> Running preflight checks ...
===> Check if /var/lib/kafka/data is writable ...
Command [/usr/local/bin/dub path /var/lib/kafka/data writable] FAILED !

I tried a lot of changes but nothing seems to work

USER root

RUN yum -y update --disableplugin=subscription-manager && \ 
	yum -y upgrade --disableplugin=subscription-manager && \
	groupadd -g 1001 fcigroup && \
  useradd -u 1001 -g 1001 -m fciuser && \
  chown -R fciuser: /var/lib/kafka && \
  chown -R fciuser: /home && \
  chown -R fciuser: /etc && \
  chown -R fciuser: /var/lib/kafka/data && \
  chmod -R 777 /var/log/kafka && \
  chmod -R 777 /home && \
  chmod -R 777 /etc/kafka && \
  chmod -R 777 /var/lib/kafka && \
  chmod -R 777 /var/lib/kafka/data

USER 1001

I even removed USER 1001 but even that didn’t seem to solve my issue

USER root

RUN yum -y update --disableplugin=subscription-manager && \ 
	yum -y upgrade --disableplugin=subscription-manager && \
  chmod -R a+rwx /var/log/kafka && \
  chmod -R a+rx /home && \
  chmod -R a+rwx /var/lib/kafka && \
  chmod -R a+rwx /var/lib/kafka/data && \
  chmod -R a+rwx /etc/kafka

I had to add /etc/kafka because earlier even that was throwing similar error

Any help is appreciated

Issue Analytics

  • State:closed
  • Created 2 years ago
  • Comments:12 (4 by maintainers)

github_iconTop GitHub Comments

andrewegelcommented, Jan 4, 2022

yes, we are deploying on an openshift cluster… Is there an issue I can track or will you be using this one?

Great, thanks for confirming - We can track things here. I have some in-flight PRs I’ll list here that I believe will resolve things:

Internally we’re testing these changes to validate things are resolved before we merge & do mass rebuilds & re-releases of images. ETA is within the next couple of weeks. I will update things here as we make progress.

andrewegelcommented, Jan 12, 2022

Hello folks-

After verifying these fixes worked in an OpenShift cluster with a random-uid-but-root-group runAs user, we have verified that this issue is no longer present. For the time being, I have pushed new a new 6.2.2-3-ub8 tag, and updated the 6.2.2 tag to these new images.

The following releases will also see this update something this week (I will update this issue as we release them):

  • 5.4.6
  • 5.5.7
  • 6.0.5
  • 6.1.4
  • 7.0.1


  • Pushed new tags 5.4.6, 5.4.6-3-deb8, 5.4.6-3-deb9, 5.4.6-3-ubi8 on 01-10-2022
  • Pushed new tags 5.5.7, 5.5.7-3-deb8, 5.5.7-3-deb9, 5.5.7-3-ubi8 on 01-10-2022
  • Pushed new tags 6.0.5, 6.0.5-3-ubi8 on 01-11-2022
  • Pushed new tags 6.1.4, 6.1.4-3-ubi8 on 01-11-2022
  • Pushed new tags 6.2.2, 6.2.2-3-ubi8 on 01-10-22
  • Pushed new tags 7.0.1, 7.0.1-3-ubi8, latest, latest-ubi8 on 1-11-2022
Read more comments on GitHub >

github_iconTop Results From Across the Web

Latest tag fails with "Command [/usr/local/bin/dub path /etc/ ...
Tried to update my containers today, but gets this error.
Read more >
Change zookeeper user id for kafka docker images
I was able to successfully run version 4.0.0 but its failing for newer version. ... Check if /var/lib/zookeeper/data is writable .
Read more >
(No title)
Im using docker swarm to set up a kafka-queue container. for some reason since 3 days ago, the kafka-queue fails to start with...
Read more >
Docker error on OS X (with new Docker)
I ran these commands: ... PS: I tried to run Kafka without Docker a few days ago, again, I failed. ... kafka_1 |...
Read more >
Developer Guide — Confluent Platform 3.1.2 documentation
dub path /etc/kafka/ writable curl -XGET ZOOKEEPER_SERVER_CONFIG_URL > /etc/kafka/ curl -XGET ZOOKEEPER_SERVER_ID_URL > /var/lib/zookeeper/ ...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found