Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

[0.9.1] Windows 10 WSL2 installation not detected

See original GitHub issue

Bug description

Can’t install Podman through the Podman Desktop Dashboard because it is not recognizing my WSL2 installation.

Operating system

Windows 10 Pro



Steps to reproduce

This version of windows requires a manual installation of the wsl2 kernel:

I’ve already own an OpenSuse Tumbleweed configured with version 2 before: wsl2-2

Install the Podman Desktop application then, on the Dashboard, try to install Podman: podman-install

Relevant log output

No response

Additional context

This version of wsl2 does not support newer commands as wsl --status: wsl2-3

wsl --install is not a valid command either: wsl2-4

My spec: Intel® Core™ i7-10510U CPU @ 1.80GHz 2.30 GHz 16,0 GB RAM Windows 10 Pro 20H2 build 19042.985

Ps.: not on Windows Insiders Program

Issue Analytics

  • State:closed
  • Created 10 months ago
  • Comments:11 (2 by maintainers)

github_iconTop GitHub Comments

albertowdcommented, Nov 22, 2022

@benoitf So, the issue is that the Windows Feature “Windows Subsystem for Linux” is not installed? Please verify using Start and search for

“Turn Windows Features on or off” image

Which will show the following dialog: image

Can you see the setting for “Windows Subsystem for Linux” ? If you do not see the checkbox, see if you can install this. This action needs administrative privileges, but should work also for users with local administrator rights. if you do not have this, it is not something we can resolve.

Tried to install, but failed as I don’t have administration rights on this machine. If this is a requirement, it could be checked in the Desktop application as well.

This would need to be checked as a pre-requisite from the provider before starting the install process.

Yep, the Windows Subsystem for Linux is installed and the Virtual Machine Platform as well (both required to run WSL2): features

As I showed in the issue form, I’ve already have a fully functional WSL2 installation of OpenSuse Tumbleweed. This is how I use Podman on my machine before tried the Podman Desktop application. Everything works besides the deployment probes (requires systemd on the instance to check liveness and so on…) podman-opensuse wsl2

Again, if I can help to solve this issue, be my guest!

IMPORTANT I found only one way to check if there is a valid Windows 10 WSL2 installation without admin rights:

  • setting the default version and checking for errors. As the Windows 10 CLI does not give us much choice, does not list online distros or only show us the version of already installed distros, my only clue of whats available on the installation was to try setting the version 2 as default value: wsl-check

I hope it helps you guys!

albertowdcommented, Nov 22, 2022

Note: so the administrator helped to install the necessary components, right?

That’s precise, I’ve asked for the administration to install the WSL requirements and the new WSL2 kernel so I could install any container engine that I wanted as a normal user.

I’ll try to see what can be done.


Read more comments on GitHub >

github_iconTop Results From Across the Web

Troubleshooting Windows Subsystem for Linux | Microsoft Learn
I'm on Windows 10 version 1903 and I still do not see options for WSL 2 ... This is likely because your machine...
Read more >
How to Install WSL 2 on Windows 10 (Updated) - OMG! Ubuntu!
to install WSL 2 on Windows 10 OS Build 2004 or later you need to open the command prompt app with Administrator permissions,...
Read more >
WSL2 - Issue with upgrading · Issue #220 · wardenenv/warden
After running brew upgrade davidalger/warden/warden (upgrade from 0.9.0 to 0.9.1) and warden svc up I got the following message: Everything else works fine ......
Read more >
How to install Ansible in Windows 10 WSL Windows ...
How to install and maintain Ansible inside Windows 10 using the Windows Subsystem for Linux and Ubuntu 20.04 LTS.
Read more >
Docker WSL 2 installation is incomplete - Super User
2 - Without using WSL 2 based engine ... Required Windows feature(s) not enabled: Hyper-V. Switch to WSL 2 based ... Hyper-V in...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found