Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

import --no-update option doesn't work

See original GitHub issue
contentful space import --no-update --content-file output.json
Usage: contentful space import --content-file <file>

  -h, --help                 Show help                                 [boolean]
  --space-id                 ID of the destination space                [string]
  --environment-id           ID the environment in the destination space
                                                    [string] [default: "master"]
  --content-file             JSON file that contains data to be import to your
                             space                           [string] [required]
  --content-model-only       Import only content types[boolean] [default: false]
  --skip-content-model       Skip importing content types and locales
                                                      [boolean] [default: false]
  --skip-locales             Skip importing locales   [boolean] [default: false]
  --skip-content-publishing  Skips content publishing. Creates content but does
                             not publish it           [boolean] [default: false]
  --no-update                Skips updating entries if they already exist
                                                      [boolean] [default: false]
  --error-log-file           Full path to the error log file            [string]
  --management-host          Management API host
                                        [string] [default: ""]
  --proxy                    Proxy configuration in HTTP auth format:
                             [http|https]://host:port or
                             [http|https]://user:password@host:port     [string]
  --config                   An optional configuration JSON file containing all
                             the options for a single run

Copyright 2018 Contentful, this is a BETA release

Unknown argument: update

Version 0.14.1 on Mac

Issue Analytics

  • State:closed
  • Created 5 years ago
  • Comments:8 (4 by maintainers)

github_iconTop GitHub Comments

chrislambecommented, Aug 20, 2018

@Khaledgarbaya Any reason not to just embrace the yargs convention? All you have to do is change it from 'no-update' to 'update' and flip the default from false to true.

phoebeschmidtcommented, Jul 1, 2019

🎉 This issue has been resolved in version 0.33.2 🎉

The release is available on:

Your semantic-release bot 📦🚀

Read more comments on GitHub >

github_iconTop Results From Across the Web

Cannot import an update from Microsoft update catalog to Wsus
Hi, I have to import a specific update but I cannot see the button import on Internet Microsoft Update catalog page. Instead I...
Read more >
Product import is not allowing updates for item type SKU ...
talks about creating new options but doesn't mention using export->edit->import to *update* SKU options. I assume this is possible(?) I have over 1300 ......
Read more >
FIX: Windows 10 Update Service is Missing (Solved) - YouTube
FIX: Windows 10 Update Service is Missing (Solved). Watch later. Share. Copy link. Info. Shopping. Tap to unmute. If playback doesn't begin ...
Read more >
Configure Update Options for Import - Quantrix
To use the "On Update, Put imported data in" option, click the green Pencil icon (the Pencil icon is disabled unless there is...
Read more >
Issue with 'update found set' import option - Claris Community
... data from one field before importing (not via the script) using the update found set option. As in the script, we matched...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found