Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out. fails on Windows

See original GitHub issue

examples/ fails on Windows (cpuonly machine) on a clean environment. Works fine on Linux.

Connected to pydev debugger (build 201.8743.20)
C:\Users\w-32\Anaconda3\envs\avalanche-env\lib\site-packages\torch\cuda\ UserWarning: CUDA initialization: Found no NVIDIA driver on your system. Please check that you have an NVIDIA GPU and installed a driver from (Triggered internally at  ..\c10\cuda\CUDAFunctions.cpp:100.)
  return torch._C._cuda_getDeviceCount() > 0
Creating the benchmark...
Starting training...
Starting task: 0
Epoch:  0
Traceback (most recent call last):
  File "C:\Users\w-32\Anaconda3\envs\avalanche-env\lib\multiprocessing\", line 93, in __init__
    reduction.dump(process_obj, to_child)
  File "C:\Users\w-32\Anaconda3\envs\avalanche-env\lib\multiprocessing\", line 60, in dump
    ForkingPickler(file, protocol).dump(obj)
AttributeError: Can't pickle local object 'main.<locals>.<lambda>'
Traceback (most recent call last):
  File "C:\Users\w-32\Anaconda3\envs\avalanche-env\lib\multiprocessing\", line 126, in _main
    self = reduction.pickle.load(from_parent)
EOFError: Ran out of input

Issue Analytics

  • State:closed
  • Created 3 years ago
  • Comments:5 (2 by maintainers)

github_iconTop GitHub Comments

AntonioCartacommented, Jan 27, 2021

@AntonioCarta just curious, why don’t you use WSL on Windows?

I usually do. avalanche’s dependencies should support Windows, so I expected everything to work fine in this case. I guess at this stage of the development we can ignore Windows bugs if we explictly say that we do not support it.

vlomonacocommented, Jan 27, 2021

Yes, we should aim to support well windows only for Avalanche official release v1.0, I believe!

Read more comments on GitHub >

github_iconTop Results From Across the Web fails · Issue #199 · microsoft/DeepSpeed - GitHub
I'm trying simply to build the library under Windows 10. I ran the following command : python install I got the following...
Read more >
Fatal Python error on Windows 10 ModuleNotFoundError
I ran into this same issue on Windows 10. Here's how I fixed it: Open your 'Environment Variables' (Under 'System Properties'). In the...
Read more >
running python executable file error in window server
The error you're currently receiving is mostly related to a corruption in the Visual C++ redistributable package. We recommend downloading the ...
Read more >
How to Fix Python Was Not Found Run Without ... - YouTube
How to Fix Python Was Not Found Run Without Arguments to Install From the Microsoft Store Error. 165K views 1 year ago.
Read more >
Genesys Cloud Developer Forum
Hi all, I am trying to use the python SDK in a new project, the dev box is a windows 10 machine, I...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found