Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

GitHubError: Validation Failed (422)

See original GitHub issue

Hello, I’m getting the following error when running conventional-github-releaser -p angular

GitHubError: Validation Failed (422)
npm ERR! errno 1
npm ERR! angular-project-starter@1.2.0 github-release: `conventional-github-releaser -p angular`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the angular-project-starter@1.2.0 github-release script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /Users/Sammy/.npm/_logs/2017-11-20T16_07_15_550Z-debug.log

Here’s the log file in question:

0 info it worked if it ends with ok
1 verbose cli [ '/usr/local/Cellar/node/8.7.0/bin/node',
1 verbose cli   '/usr/local/bin/npm',
1 verbose cli   'run',
1 verbose cli   'github-release' ]
2 info using npm@5.5.1
3 info using node@v8.7.0
4 verbose run-script [ 'pregithub-release', 'github-release', 'postgithub-release' ]
5 info lifecycle angular-project-starter@1.2.0~pregithub-release: angular-project-starter@1.2.0
6 info lifecycle angular-project-starter@1.2.0~github-release: angular-project-starter@1.2.0
7 verbose lifecycle angular-project-starter@1.2.0~github-release: unsafe-perm in lifecycle true
8 verbose lifecycle angular-project-starter@1.2.0~github-release: PATH: /usr/local/lib/node_modules/npm/bin/node-gyp-bin:/Users/Sammy/Projects/angular-project-starter/node_modules/.bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin
9 verbose lifecycle angular-project-starter@1.2.0~github-release: CWD: /Users/Sammy/Projects/angular-project-starter
10 silly lifecycle angular-project-starter@1.2.0~github-release: Args: [ '-c', 'conventional-github-releaser -p angular' ]
11 silly lifecycle angular-project-starter@1.2.0~github-release: Returned: code: 1  signal: null
12 info lifecycle angular-project-starter@1.2.0~github-release: Failed to exec github-release script
13 verbose stack Error: angular-project-starter@1.2.0 github-release: `conventional-github-releaser -p angular`
13 verbose stack Exit status 1
13 verbose stack     at EventEmitter.<anonymous> (/usr/local/lib/node_modules/npm/node_modules/npm-lifecycle/index.js:280:16)
13 verbose stack     at emitTwo (events.js:125:13)
13 verbose stack     at EventEmitter.emit (events.js:213:7)
13 verbose stack     at ChildProcess.<anonymous> (/usr/local/lib/node_modules/npm/node_modules/npm-lifecycle/lib/spawn.js:55:14)
13 verbose stack     at emitTwo (events.js:125:13)
13 verbose stack     at ChildProcess.emit (events.js:213:7)
13 verbose stack     at maybeClose (internal/child_process.js:927:16)
13 verbose stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:211:5)
14 verbose pkgid angular-project-starter@1.2.0
15 verbose cwd /Users/Sammy/Projects/angular-project-starter
16 verbose Darwin 16.7.0
17 verbose argv "/usr/local/Cellar/node/8.7.0/bin/node" "/usr/local/bin/npm" "run" "github-release"
18 verbose node v8.7.0
19 verbose npm  v5.5.1
20 error code ELIFECYCLE
21 error errno 1
22 error angular-project-starter@1.2.0 github-release: `conventional-github-releaser -p angular`
22 error Exit status 1
23 error Failed at the angular-project-starter@1.2.0 github-release script.
23 error This is probably not a problem with npm. There is likely additional logging output above.
24 verbose exit [ 1, true ]

Issue Analytics

  • State:open
  • Created 6 years ago
  • Reactions:7
  • Comments:11 (2 by maintainers)

github_iconTop GitHub Comments

francoisromaincommented, May 8, 2019

it works for me now. I am not sure about what solved the problem, but two things chnaged:

  • standard-version was updated from v 5.0.2 to 6.0.1
  • I fixed the url of the repo in package.json which was pointing to a wrong place
Kikobeatscommented, Oct 13, 2021

This is happening mainly if you try to create a release that already exists:

curl -X POST -H "Authorization: token GH_TOKEN" \
    -d '{ "tag_name": "v2.0.8", "generate_release_notes: true }'
  "message": "Validation Failed",
  "errors": [
      "resource": "Release",
      "code": "already_exists",
      "field": "tag_name"
  "documentation_url": ""

In that case, the library could fall back into update the release. There is an endpoint for doing that:

Read more comments on GitHub >

github_iconTop Results From Across the Web

pyGithub Pull request invalid head (422 API error)
Ultimately I was able to make a PR using , but unfortunately I can't see a way to avoid it opening ...
Read more >
How to use conventional-github-releaser - remarkablemark
Why is conventional-github-releaser failing with GitHubError: Validation Failed (422)?§ · The release for the version already exists on GitHub.
Read more >
Unable to add new project. GitHub error - CircleCI Discuss
Checking developer tools, here is the error from your servers: HTTP 422 Unprocessable Entity Response {"message":"{\"mess…
Read more >
"Validation failed" when try to create pull request - Apache
While I can't guarantee that is what's causing the github error, it is most likely considering you are trying to create a PR...
Read more >
Debian Bug report logs - #807862 fails to create PR
... from branch docs-ml to borgbackup/borg:docs-ml Error: GitHub error: Validation Failed Error: HTTP Error 422: Unprocessable Entity Error: ...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found