Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Various upgrade issues

See original GitHub issue

I’ve noticed new releases for cornerstone and its companion tool project:

  • cornerstone-core (0.12.1) (previously 0.11.0)
  • cornerstone-tools (0.9.0) (previously 0.8.9)

It may be worth noting that I load images using the cornerstone-web-image-loader package.

When I run npm install cornerstone-tools@0.9.0 --save, at runtime I get the following error:

element is not enabled

Thinking I need to update to the latest cornerstone-core to resolve the issue, I run npm install cornerstone-core@0.12.1 --save, but I see the following error at runtime:

loadImageFromImageLoader: no image loader for imageId

No other changes. Only package updates. If I revert, delete node_modules, and restore all packages, I am able to continue development.

Any/all help is appreciated.

Issue Analytics

  • State:closed
  • Created 6 years ago
  • Comments:5 (2 by maintainers)

github_iconTop GitHub Comments

henryhe1commented, Jun 19, 2018

Had this problem as well updating from a previous version of Cornerstone. You need to load the cornerstoneWADOImageLoaderCodecs.js and cornerstoneWADOImageLoaderWebWorker.js scripts as well if you are using the WADO loader. Then I have this at the beginning of my main script after loading dependencies:

cornerstoneWADOImageLoader.external.cornerstone = cornerstone;

var config = {
    webWorkerPath : 'new/js/frameworks/cornerstoneWADOImageLoaderWebWorker.js',
    taskConfiguration: {
        'decodeTask' : {
            // path of the codecs file. For some reason I have to access it differently than WebWorker even though it's at the same location? Not sure, but it works lol
            codecsPath: '../../../new/js/frameworks/cornerstoneWADOImageLoaderCodecs.js'


Hope that helps

swederikcommented, Nov 10, 2017

I think this has now been fixed with the dependency injection work. You would need to add this somewhere, though:

cornerstoneWebImageLoader.external.cornerstone = cornerstone;
Read more comments on GitHub >

github_iconTop Results From Across the Web

6 Common Windows Upgrade Issues & How to Fix Them
Upgrading Windows 10 can cause a number of complications. We show you what to watch out for and how to prevent or fix...
Read more >
Windows 11 upgrade issues that desktop admins should know
The Windows 11 upgrade process has suffered from various issues ranging from hardware incompatibilities and cryptic error messages to post- ...
Read more >
10 things that can go wrong when you upgrade your operating ...
#3: Driver problems. Driver problems are one of the most common causes of all sorts of trouble connected with an OS upgrade. Just...
Read more >
10 Challenges To Think About When Upgrading From Legacy ...
10 Challenges To Think About When Upgrading From Legacy Systems · 1. User Acceptance · 2. Workflow Issues · 3. Unknown Dependencies ·...
Read more >
Windows 10 upgrade failed? Use these 5 tools to find the ...
The most common upgrade errors can be traced to a handful of basic causes: software incompatibilities, storage-related issues, and errors in the ...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found