Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Error when trying to use --check-native

See original GitHub issue

When trying to run ProtonDB-Tag with --check-native argument, I get the following error

Steam found at: /home/beergeekgamer/.local/share/Steam/userdata
Found user 0: 19755583   BeerGeekGamer
Only one user found.
Selected: /home/beergeekgamer/.local/share/Steam/userdata/19755583/7/remote/sharedconfig.vdf
Steam native cache not found.
Creating Steam native cache...
Traceback (most recent call last):
  File "ProtonDB-Tags", line 299, in <module>
  File "ProtonDB-Tags", line 230, in main
    if check_native and is_native(app_id):
  File "ProtonDB-Tags", line 53, in is_native
    with open(cache_path, 'w') as cache_file:
PermissionError: [Errno 13] Permission denied: './steamNativeCache.json'

Issue Analytics

  • State:closed
  • Created 4 years ago
  • Comments:11 (5 by maintainers)

github_iconTop GitHub Comments

ShayBoxcommented, Sep 8, 2019

Ah, well that would be the problem, system packages are always installed into a system binary folder users have no access writing to, and non binary files shouldn’t go, so the script should be accessing a local user folder, the script should be following the XDG spec in this case, $XDG_CACHE_HOME/protondb-tags/<cache file(s)> with $HOME/.cache/protondb-tags/<cache file(s)> as a fallback if the env doesn’t exist.

EDIT: I don’t know python well enough, but somewhere around here, check if the platform is linux, and if so instead of ./steamNativeCache.json check if $XDG_CACHE_HOME is an env, and if it is, use $XDG_CACHE_HOME/protondb-tags/steamNativeCache.json and if it’s not use $HOME/.cache/protondb-tags/steamNativeCache.json

This would be the way to fix it on linux, I can’t speak for how to handle it on mac, usually you put this stuff in appdata on windows in roaming or local

CorruptComputercommented, Sep 7, 2019

@ShayBox steamNativeCache.json is created by the script. The file is in the same directory that the script is in. Depending on where the AUR build script clones the script to this may be somewhere that unprivileged users do not have access.

Read more comments on GitHub >

github_iconTop Results From Across the Web

Solved: Failed to load native-hadoop with error:libhadoop....
Solved: Hi, I am using Cloudera CDH 5.4.4. ... NativeCodeLoader: Trying to load the custom-built native-hadoop library.
Read more >
[jira] [Updated] (HADOOP-12638) UnsatisfiedLinkError while ...
ZlibFactory: Failed to load/initialize native-zlib library Exception in thread "main" java.lang.UnsatisfiedLinkError: org.apache.hadoop.util.
Read more >
Hadoop 2.6.1 Warning: WARN util.NativeCodeLoader
Open the and go to the end of the file and try to add the following lines ... getConfiguration(); //To access HDFS...
Read more >
Building Hadoop on macOS Monterey? - The Mail Archive
Hi, Curious if anyone has tips for building Hadoop on macOS Monterey, for Apple Silicon? My goal is to be able to use...
Read more >
The mobile app must be tagged in LifeTime and generated error
When I try to download the IPA for my app I get this error: ... Check Native Platforms tab for more details. ......
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found