Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Blank ClusterView and SimilarityView

See original GitHub issue


I got some problem to start with a template-gui on my kilosort result. The ClusterView and SimilarityView didn’t show anything. No mater how long I wait, it didn’t change the blank content. If I tried to close the window, a timeout dialog pop up.


Here are the part of packages installed in my conda environment.

# Name                    Version                   Build  Channel
pyqt5                     5.15.5                   pypi_0    pypi
pyqt5-qt                  5.15.2                   pypi_0    pypi
pyqt5-qt5                 5.15.2                   pypi_0    pypi
pyqt5-sip                 12.9.1                   pypi_0    pypi
pyqtwebengine             5.15.5                   pypi_0    pypi
pyqtwebengine-qt          5.15.2                   pypi_0    pypi
pyqtwebengine-qt5         5.15.2                   pypi_0    pypi
pytest-qt                 3.2.2                    pypi_0    pypi
qtconsole                 4.5.5                    pypi_0    pypi
phy                       2.0a1                    pypi_0    pypi
phylib                    2.4.1                    pypi_0    pypi

I guess it is something relate to the QtWebEngine which js wasn’t run.


Issue Analytics

  • State:open
  • Created 2 years ago
  • Comments:6 (1 by maintainers)

github_iconTop GitHub Comments

AntonioSTcommented, Mar 18, 2022

Hi @AliyaAbl

I don’t the real reason why qtwebengine is unable to show html content, but this command works on my linux computer env QTWEBENGINE_CHROMIUM_FLAGS="--single-process" phy template-gui .../


I just find out this way this morning. I tried a simple QWebEngineView example with conda Qt (pyqtwebengine-qt 5.15.2 from conda pypi chanel), and my OS Qt (python-pyqt5-webengine-5.15.5-4 from archlinux). I have no such issue with my OS Qt.

KBillelcommented, Oct 24, 2022

Worked for me as well thank you !

Read more comments on GitHub >

github_iconTop Results From Across the Web

Interactive visualization of ephys data - Read the Docs
Similarity view. The similarity view is very similar to the cluster view. It has an additional column: the similarity. It represents the similarity...
Read more >
KlustaViewas - Google Groups
Re-opening ClusterView and SimilarityView. Hi, you can delete the ~/.phy folder in your HOME directory, and reopen phy. This will reset the GUI....
Read more >
Revision - 6ffe05a - WIP: improve choice of phylib branch in travis ...
SimilarityView ](#phyclustersimilarityview) ... List of view names to create by default (overriden by `view_count` if not empty). ... ClusterView.eval_js.
Read more >
Visual Analytics of Patterns in High-Dimensional Data - Universität ...
clusters are projected in the cluster view to a 2D scatterplot using MDS based on ... dimension-similarity view (based on Tanimoto distance) are...
Read more >
ICGenealogy: Mapping the function of neuronal ion - bioRxiv
a similarity view focusing on the channel's response kinetic scores (Figure ... middle), and a circular cluster view (Figure 7B, bottom).
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found