Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Problems installing phy

See original GitHub issue

I encountered a weird error while trying to reinstall phy. Phy was working well on my machine after initial installation, but stopped working after rebooting my computer. I have reinstalled miniconda, and tried to reinstall phy, but I keep running into the following error when typing conda env create -n phy:

AttributeError: '_NamespacePath' object has no attribute 'sort'
An unexpected error has occurred.
Please consider posting the following information to the
conda GitHub issue tracker at:

Current conda install:

               platform : win-64
          conda version : 4.2.12
       conda is private : False
      conda-env version : 4.2.12
    conda-build version : not installed
         python version :
       requests version : 2.11.1
       root environment : C:\Users\jgeerts\AppData\Local\Continuum\Miniconda3  (
    default environment : C:\Users\jgeerts\AppData\Local\Continuum\Miniconda3
       envs directories : C:\Users\jgeerts\AppData\Local\Continuum\Miniconda3\en
          package cache : C:\Users\jgeerts\AppData\Local\Continuum\Miniconda3\pk
           channel URLs :
            config file : None
           offline mode : False

`$ C:\Users\jgeerts\AppData\Local\Continuum\Miniconda3\Scripts\conda-env-script.
py create -n phy`

    Traceback (most recent call last):
      File "C:\Users\jgeerts\AppData\Local\Continuum\Miniconda3\lib\site-package
s\conda\", line 479, in conda_exception_handler
        return_value = func(*args, **kwargs)
      File "C:\Users\jgeerts\AppData\Local\Continuum\Miniconda3\lib\site-package
s\conda_env\cli\", line 111, in execute
        installer.install(prefix, pkg_specs, args, env)
      File "C:\Users\jgeerts\AppData\Local\Continuum\Miniconda3\lib\site-package
s\conda_env\installers\", line 8, in install
        pip_cmd = pip_args(prefix) + ['install', ] + specs
      File "C:\Users\jgeerts\AppData\Local\Continuum\Miniconda3\lib\site-package
s\conda_env\", line 30, in pip_args
        pip_version = subprocess.check_output(ret + ['-V']).decode('utf-8').spli
      File "C:\Users\jgeerts\AppData\Local\Continuum\Miniconda3\lib\subprocess.p
y", line 626, in check_output
      File "C:\Users\jgeerts\AppData\Local\Continuum\Miniconda3\lib\subprocess.p
y", line 708, in run
        output=stdout, stderr=stderr)
    subprocess.CalledProcessError: Command '['C:\\Users\\jgeerts\\AppData\\Local
\\Continuum\\Miniconda3\\envs\\phy\\python.exe', 'C:\\Users\\jgeerts\\AppData\\L
ocal\\Continuum\\Miniconda3\\envs\\phy\\Scripts\\', '-V']' returned
 non-zero exit status 1

Issue Analytics

  • State:closed
  • Created 7 years ago
  • Comments:9 (3 by maintainers)

github_iconTop GitHub Comments

arnal46commented, Feb 23, 2017

At first, thank you for the answer! I was installed the gcc and part of the issue disappeared… but the phy software didn’t run.

I find the solution: NOT install miniconda from that webpage

You have to install the version 4.1.11 (in my particular case because it have python 3.5.2. The other installs the 3.6 version and it seems is not compatible. Link to find it:

I commented the next steps for help to install “more easy”:

  1. Download the environment.yml file. (and replace the original file in ‘phy-master’ folder and copy requirements-dev.txt and paste it and rename the copy to: requirements.txt)

  2. Open a terminal (on Windows, cmd, not Powershell) in the directory where you saved the file (‘phy-master’) and type:

conda env create -n phy
source activate phy  # omit the `source` on Windows
pip install phy phycontrib
  1. Done! Now, to use phy, you have to first type source activate phy in a terminal (omit the source on Windows), and then call phy.
caraslabcommented, Mar 27, 2019

I was able to get Phy to install by removing klustakwik2 from the environment.yml file. The rest of the libraries installed just fine, and I confirmed with Cyrille that if you’re using Phy with data that’s been processed with kilosort (as I am doing), there’s no need for klustakwik2. Not sure what kind of sorting program you’re using though, so double check first that you don’t actually need klustakwik2. If you do… sorry, I still haven’t found a solution to get it to install. If you find a solution, please do let me know!

Read more comments on GitHub >

github_iconTop Results From Across the Web

Problems installing phy · Issue #742 · cortex-lab/phy - GitHub
I was able to get Phy to install by removing klustakwik2 from the environment.yml file. The rest of the libraries installed just fine,...
Read more >
phy install issues - Google Groups
Hi All, I've just tried to install phy using the quick install instructions on Windows. There is a previous installation of klusta-suite running...
Read more >
Troubleshooting - phy - Read the Docs
Troubleshooting. Here are a few tips if something goes wrong. GitHub issues. Look at existing GitHub issues to see if someone else had...
Read more >
phy · PyPI
In some environments, you might get an error message related to QtWebEngineWidget. Run the command pip install PyQtWebEngine and try launching phy again....
Read more >
Installation | REST-for-Physics
This script may fail, if it is the case, do not run the script again, just go to the generated build directory, usually...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found