Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Tries to create label when label already exists

See original GitHub issue

Hi! I’ve been testing out different action for syncing labels in a repo and your action lines up perfectly with what we need.

I keep running into an issue where the action doesn’t recognize one of my labels right away. When running the action then it attempts to create the label then fails saying a label with that name already exists:

🎨 Creating 'wontfix' label with color 'ffffff' and desc 'This will not be worked on'
##[error]Validation Failed: {"resource":"Label","code":"already_exists","field":"name"}

The label is listed under my labels with the same fields above. All of the other labels are properly being skipped over, but I’m unsure why this one isn’t?

I also tried using the from_name: with wontfix and it says the label can’t be found in order to rename it.

Let me know if there’s any more information you need to help with this or if you have any guidance/things to try to fix this issue! Thanks!

Issue Analytics

  • State:closed
  • Created 3 years ago
  • Comments:24 (13 by maintainers)

github_iconTop GitHub Comments

ces131commented, Apr 8, 2020

@crazy-max cool! thanks again!!

crazy-maxcommented, Apr 8, 2020

@ces131 Should be ok to bring back crazy-max/ghaction-github-labeler@v1

Read more comments on GitHub >

github_iconTop Results From Across the Web

New Label: A label with the name already exists - MSDN
The Label it's talking about is applied to a sibling folder. When I "View History / Labels" this label doesn't appear on my...
Read more >
Unable to create 'saved' label - Google Account Community
I am unable to create a 'Saved' label for my gmail account. ... it tells me that the 'Saved' label already exists when...
Read more >
Error while Creating a new Label in the existing label file
I have a scenario wherein I am creating a new label. I have crossed checked the label file exists in the system and...
Read more >
Node(ID) already exists with label `X` and properties `y` = 'z ...
I created an unicity constraint for LinkedEntity where prop1 and prop2 must be unique ( ASSERT (n.prop1, n.prop2) ). Now when a LinkedEntity ......
Read more >
How can I skip the label if the value label already exists on my ...
I have a dropdown select field where I can choose different attributes value. The problem is when I try to store the selected...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found