Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

CI: ImportError: cannot import name 'AsyncGeneratorType

See original GitHub issue

see eg


cachedir: .tox/coverage/.pytest_cache

rootdir: /home/travis/build/crossbario/autobahn-python, inifile: setup.cfg

plugins: asyncio-0.10.0, twisted-1.12

collected 172 items / 7 errors / 165 selected                                  

==================================== ERRORS ====================================

_ ERROR collecting .tox/coverage/lib/python3.5/site-packages/autobahn/asyncio/test/ _

ImportError while importing test module '/home/travis/build/crossbario/autobahn-python/.tox/coverage/lib/python3.5/site-packages/autobahn/asyncio/test/'.

Hint: make sure your test modules/packages have valid Python names.


.tox/coverage/lib/python3.5/site-packages/autobahn/asyncio/test/ in <module>

    from autobahn.asyncio.rawsocket import PrefixProtocol, RawSocketClientProtocol, RawSocketServerProtocol, \

.tox/coverage/lib/python3.5/site-packages/autobahn/asyncio/ in <module>

    from autobahn.asyncio.websocket import \

.tox/coverage/lib/python3.5/site-packages/autobahn/asyncio/ in <module>


.tox/coverage/lib/python3.5/site-packages/txaio/ in use_asyncio

    from txaio import aio

.tox/coverage/lib/python3.5/site-packages/txaio/ in <module>

    from types import AsyncGeneratorType

E   ImportError: cannot import name 'AsyncGeneratorType'

Issue Analytics

  • State:closed
  • Created 4 years ago
  • Comments:6 (3 by maintainers)

github_iconTop GitHub Comments

github_iconTop Results From Across the Web

ImportError: cannot import name 'AsyncGenerator' · Issue #530
I may be missing something embarrassingly obvious here, but I'm getting a consistent import error for AsyncGenerator using 3.6.0.
Read more >
Cannot get Jupyter Notebook To Run - "Cannot Import Name ...
According to a Github issue related to the same error text: ... a workaraound is to set if TYPE_CHECKING: from typing import AsyncGenerator....
Read more >
jupyter notebook cannot import name 'soft_unicode ... -
I encounter this error message when i tried to launch jupyter notebook. Any kind soul can advise how rectify this issue? Traceback (most...
Read more >
python/typing - Gitter
Gidday! I'm trying to create an abstract async generator. Mypy doesn't like it. @abstractmethod async def _aenter(self) -> AsyncGenerator[AsyncContextManager[ ...
Read more >
typing — Faust 1.9.0 documentation
import abc from abc import abstractmethod, abstractproperty import collections ... Args: name: The name, e.g. 'Pattern'. type_var: The type parameter, ...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found