Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

NoClassDefFoundError kotlin/jvm/internal/Intrinsics

See original GitHub issue


This error occures with the new version 1.1.1

java.lang.NoClassDefFoundError: Failed resolution of: Lkotlin/jvm/internal/Intrinsics;
	at nl.dionsegijn.konfetti.ParticleSystem.<init>(ParticleSystem.kt)

1.1.0 is OK.

Issue Analytics

  • State:closed
  • Created 6 years ago
  • Reactions:4
  • Comments:13 (5 by maintainers)

github_iconTop GitHub Comments

kwikycommented, May 24, 2018

@DanielMartinus finally fixed by manually adding the kotlin-stdlib-jdk7 (which was missing in graph dependencies) in my build.gradle file

    implementation 'org.jetbrains.kotlin:kotlin-stdlib-jdk7:1.2.41'
    implementation 'nl.dionsegijn:konfetti:1.1.2'

ping @arpitsharmagit

DanielMartinuscommented, Mar 22, 2018

Thanks for reporting this issue @kwiky.

There must have gone something wrong with creating the jar file is my first assumption. For the time being 1.1.0 should be sufficient to use since 1.1.1 only contains minor changes.

Read more comments on GitHub >

github_iconTop Results From Across the Web

java.lang.NoClassDefFoundError: kotlin/jvm/internal/Intrinsics ...
Adding all project files to the jar fixed the problem for me. I added the following line to my build.gradle jar { manifest...
Read more >
Exception in thread "main" java.lang.NoClassDefFoundError
NoClassDefFoundError : kotlin/jvm/internal/Intrinsics. I am getting the following error for code. fun main(args: Array) { println("hello") }.
Read more >
Not able to run jar file - Kotlin Discussions
Exception in thread "main" java.lang.NoClassDefFoundError: kotlin/jvm/internal/Intrinsics at MainfileKt.main(Mainfile.kt) Caused by: ...
Read more >
java.lang.NoClassDefFoundError: kotlin/jvm/internal/Intrinsics
I've looked up my issue here, and it said that my error has to do with a broken class path. I have no...
Read more >
[Solved]-Heroku / Kotlin: java.lang.NoClassDefFoundError
[Solved]-Heroku / Kotlin: java.lang.NoClassDefFoundError: kotlin/jvm/internal/Intrinsics-kotlin ... I'm not sure why you're getting this error. But you might want ...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found