Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Failed to npm start

See original GitHub issue

I run into this issue after npm install and start the project. Please help! p/s; I am quite new to Angular, please excuse me if I asked a silly question.

0 info it worked if it ends with ok 1 verbose cli [ ‘/usr/local/bin/node’, ‘/usr/local/bin/npm’, ‘start’ ] 2 info using npm@4.0.5 3 info using node@v6.9.3 4 verbose run-script [ ‘prestart’, ‘start’, ‘poststart’ ] 5 info lifecycle angular2-jumpstart@1.0.0~prestart: angular2-jumpstart@1.0.0 6 silly lifecycle angular2-jumpstart@1.0.0~prestart: no script for prestart, continuing 7 info lifecycle angular2-jumpstart@1.0.0~start: angular2-jumpstart@1.0.0 8 verbose lifecycle angular2-jumpstart@1.0.0~start: unsafe-perm in lifecycle true 9 verbose lifecycle angular2-jumpstart@1.0.0~start: PATH: /usr/local/lib/node_modules/npm/bin/node-gyp-bin:/home/dungnt/Angular-JumpStart-master/node_modules/.bin:usr/local/bin:/usr/local/ant/bin:/home/dungnt/Downloads/jdk1.8.0_111/bin:usr/local/bin:/usr/local/ant/bin:/home/dungnt/Downloads/jdk1.8.0_111/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/home/dungnt/opt/gradle/bin:/home/dungnt/opt/gradle/bin 10 verbose lifecycle angular2-jumpstart@1.0.0~start: CWD: /home/dungnt/Angular-JumpStart-master 11 silly lifecycle angular2-jumpstart@1.0.0~start: Args: [ ‘-c’, 'tsc && concurrently “tsc -w” “node server.js” ’ ] 12 silly lifecycle angular2-jumpstart@1.0.0~start: Returned: code: 2 signal: null 13 info lifecycle angular2-jumpstart@1.0.0~start: Failed to exec start script 14 verbose stack Error: angular2-jumpstart@1.0.0 start: tsc && concurrently "tsc -w" "node server.js" 14 verbose stack Exit status 2 14 verbose stack at EventEmitter.<anonymous> (/usr/local/lib/node_modules/npm/lib/utils/lifecycle.js:279:16) 14 verbose stack at emitTwo (events.js:106:13) 14 verbose stack at EventEmitter.emit (events.js:191:7) 14 verbose stack at ChildProcess.<anonymous> (/usr/local/lib/node_modules/npm/lib/utils/spawn.js:40:14) 14 verbose stack at emitTwo (events.js:106:13) 14 verbose stack at ChildProcess.emit (events.js:191:7) 14 verbose stack at maybeClose (internal/child_process.js:877:16) 14 verbose stack at Process.ChildProcess._handle.onexit (internal/child_process.js:226:5) 15 verbose pkgid angular2-jumpstart@1.0.0 16 verbose cwd /home/dungnt/Angular-JumpStart-master 17 error Linux 3.13.0-37-generic 18 error argv “/usr/local/bin/node” “/usr/local/bin/npm” “start” 19 error node v6.9.3 20 error npm v4.0.5 21 error code ELIFECYCLE 22 error angular2-jumpstart@1.0.0 start: tsc && concurrently "tsc -w" "node server.js" 22 error Exit status 2 23 error Failed at the angular2-jumpstart@1.0.0 start script 'tsc && concurrently “tsc -w” “node server.js” '. 23 error Make sure you have the latest version of node.js and npm installed. 23 error If you do, this is most likely a problem with the angular2-jumpstart package, 23 error not with npm itself. 23 error Tell the author that this fails on your system: 23 error tsc && concurrently “tsc -w” “node server.js” 23 error You can get information on how to open an issue for this project with: 23 error npm bugs angular2-jumpstart 23 error Or if that isn’t available, you can get their info via: 23 error npm owner ls angular2-jumpstart 23 error There is likely additional logging output above. 24 verbose exit [ 1, true ]

Issue Analytics

  • State:closed
  • Created 7 years ago
  • Comments:7 (4 by maintainers)

github_iconTop GitHub Comments

DanWahlincommented, Jan 9, 2017

Thanks for the info. I don’t run Linux so I can’t support that unfortunately (or even try it). Here’s what I’d recommend:

Run the following commands in separate command windows:

  1. npm run tsc:w
  2. node server.js

I’m guessing the concurrently module may be the problem on Linux. Try running the commands separately and let me know if that works for you. The JumpStart app is using the same setup as the Angular docs recommend so I’m guessing their demos may have a problem on Linux as well.

DanWahlincommented, Jan 9, 2017

No problem - I’ve seen that fsevents error as well and it definitely makes it feel like it’s the main problem sometimes when it isn’t. Glad you got it going. I’m not sure why the concurrently module isn’t working for you since I have it working in other scenarios with Docker/Linux, but if you have it going now by running separate commands that’s great.

Read more comments on GitHub >

github_iconTop Results From Across the Web

npm start giving error in node.js - Stack Overflow
Failed at the nodetest1@0.0.0 start script. npm ERR! This is most likely a problem with the nodetest1 package, npm ERR! not with npm...
Read more >
How to fix start script error when running npm start command
In this video we are going to learn how to fix start script error when running npm start command.Thank You For Visiting My...
Read more >
Getting an error while running nodejs app when running locally
Run the following commands: npm install npm start Here is the package.json: ... Failed at the dashdbnodesample@0.0.1 start script 'node app.js'. npm ERR!...
Read more >
'Npm start' fails on react-scripts-start · Issue #9594 - GitHub
Exit status 1 npm ERR! npm ERR! Failed at the client@0.1.0 start script. npm ERR! This is probably not a problem with npm....
Read more >
"The NPM script 'start' exited without indicating that the create ...
I've tried everything I've seen online, and it still fails. I've executed "npm install" and a lot of npm commands I've seen in...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found