Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

problem npm run start

See original GitHub issue

OS Windows 10: C:\Users\willi\Desktop\architectui-react-free>npm run start

architectui-react-theme-free@1.0.0 start C:\Users\willi\Desktop\architectui-react-free cross-env NODE_PATH=./src node scripts/start.js

Cannot read property ‘entryOption’ of undefined npm ERR! code ELIFECYCLE npm ERR! errno 1 npm ERR! architectui-react-theme-free@1.0.0 start: cross-env NODE_PATH=./src node scripts/start.js npm ERR! Exit status 1 npm ERR! npm ERR! Failed at the architectui-react-theme-free@1.0.0 start script. npm ERR! This is probably not a problem with npm. There is likely additional logging output above. npm ERR! A complete log of this run can be found in: npm ERR! C:\Users\willi\AppData\Roaming\npm-cache_logs
2019-07-13T17_13_11_496Z-debug.log 2019-07-13T17_13_11_496Z-debug.log

Issue Analytics

  • State:closed
  • Created 4 years ago
  • Reactions:3
  • Comments:11

github_iconTop GitHub Comments

logicwarecommented, Oct 6, 2019

It runs after deleting ^ from webpack-dev-server in devDependencies package.json. But I get a blank page with warnings in console.

I am running it on a Linux Mint 19 machine.

See attached screenshot.

Screenshot from 2019-10-06 16-12-08

MU-SAcommented, Aug 13, 2019

delete ^ from webpack-dev-server in devDependencies package.json

Read more comments on GitHub >

github_iconTop Results From Across the Web

How to fix npm start command not working - Nathan Sebhastian
How to fix npm start command not working · Check if you have a package.json file in your project · Check if you...
Read more >
Unable to run "npm start" shows error. how to resolve?
Try typing npm run start alt npm r start. navigate to the same folder where the package.json is located type npm install to...
Read more >
How to fix start script error when running npm start command
In this video we are going to learn how to fix start script error when running npm start command.Thank You For Visiting My...
Read more >
npm start not working / How to fix npm error React ... - YouTube
code #coding # npm #react #coders #computerscience #cs #javascript #javaprogramming #react #reactjs if still not working please watch ...
Read more >
npm run start not working - Reddit
i've gotten it running on my physical machine but i tried starting it on a VM through linode to try and launch it...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found