Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Pattern `**/*.md` does not includes paths like `source/_posts/` while running the CLI via `npx`

See original GitHub issue

I am working in a hexo blog project, and I got

$ npx markdownlint-cli2 "**/*.md" "#node_modules"
markdownlint-cli2 v0.0.12 (markdownlint v0.22.0)
Finding: scaffolds/ scaffolds/ scaffolds/
Linting: 3 file(s)
Summary: 0 error(s)

which means **/*.md does not includes paths like source/_posts/ However, it worked pretty well in the past few days. Is something going wrong?

Issue Analytics

  • State:closed
  • Created 3 years ago
  • Comments:5 (2 by maintainers)

github_iconTop GitHub Comments

DavidAnsoncommented, Dec 23, 2020

The “Finding” line shows that whatever tool/environment is running the command is expanding the glob instead of passing it to the CLI. Maybe try single quote or run the CLI directly if “npx” is responsible?

rickygaocommented, Mar 20, 2021

A couple of months passed, and I should note here that something has changed as far as I observed. npm 7.6.3 (or maybe some version behind) brings the previous behavior back, and a command like npx markdownlint-cli2 "**/*.md" "#node_modules" works now.

Read more comments on GitHub >

github_iconTop Results From Across the Web

Running npx globally does not work on Windows when the ...
The entire path needs to be in a string, but npx seems to be splitting it into two strings. This issue seems specific...
Read more >
npx - npm Docs
This command allows you to run an arbitrary command from an npm package (either one installed locally, or fetched remotely), in a similar...
Read more >
Introducing npx: an npm package runner | by Kat Marchán
npx is a tool intended to help round out the experience of using packages from the npm registry — the same way npm...
Read more >
command not found while creating new project using angular ...
The issue is simple, npm doesn't know about ng. Just run npm link @angular/cli and it should work seamlessly.
Read more >
How to build a CLI with Node.js - Twilio
In fact npx supports executing CLIs even when they are not installed yet. ... Now that we covered why you might want to...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found