Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Issue with npm start

See original GitHub issue

I’m working through your series at the moment, still in the First Things First section, and I receive the following error when running npm start after cloning down the repo:

npm ERR! Darwin 16.3.0
npm ERR! argv "/usr/local/bin/node" "/usr/local/bin/npm" "start"
npm ERR! node v6.9.2
npm ERR! npm  v3.10.9
npm ERR! product-management@1.0.0 start: `tsc && concurrently "tsc -w" "lite-server" `
npm ERR! Exit status 2
npm ERR!
npm ERR! Failed at the product-management@1.0.0 start script 'tsc && concurrently "tsc -w" "lite-server" '.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the product-management package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     tsc && concurrently "tsc -w" "lite-server"
npm ERR! You can get information on how to open an issue for this project with:
npm ERR!     npm bugs product-management
npm ERR! Or if that isn't available, you can get their info via:
npm ERR!     npm owner ls product-management
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR!     /Users/whoami/Documents/Code/Angular/angular2-gettingstarted/APM - Start/npm-debug.log
Computer-Name:APM - Start whoami$ sudo npm start

The following Stack Overflow answer solved the issue and the project starts just fine:

Is this an issue with newer versions of Angular 2 or npm, or would this possibly be Mac specific? Might the line noted in the SO answer need to be updated within the project files? I’ve already done this and could submit it as a pull request if you’d like.

Issue Analytics

  • State:closed
  • Created 7 years ago
  • Reactions:1
  • Comments:9 (4 by maintainers)

github_iconTop GitHub Comments

degoeymcommented, Dec 21, 2016

Following an answer further down in the same SO link I provided earlier, I deleted the node_modules folder, cleared the local branch I made to then branch off a clean master from the original clone. I then re-ran npm install which worked just fine, and npm start worked perfectly after that. I believe I’m still sudo’d in my terminal, but everything seems to be running just fine with the configuration you’ve provided.

Thanks for your quick responses to this matter and for reaching out to external sources to help resolve it.

ramirezm2014commented, Dec 28, 2016

I just did.

Thank you

On Dec 28, 2016 3:21 PM, “Matt DeGoey” wrote:

I think this question is better suited to being asked on the main Pluralsite page for the video series.

— You are receiving this because you commented. Reply to this email directly, view it on GitHub, or mute the thread .

Read more comments on GitHub >

github_iconTop Results From Across the Web

How to fix npm start command not working - Nathan Sebhastian
How to fix npm start command not working · Check if you have a package.json file in your project · Check if you...
Read more >
npm start giving error in node.js - Stack Overflow
json . The package. json is telling npm that start means "run node ./bin/www". What happens when you run that same script from...
Read more >
npm err! missing script: start Solution - Career Karma
If you type npm start and get the npm err! missing script: start error, there must be a missing line in the script...
Read more >
npm-start - npm Docs
If the "scripts" object does not define a "start" property, npm will run node server.js . Note that this is different from the...
Read more >
npm start not working, tried many solves :| #1328 - GitHub
derweili commented on Jan 17, 2019 · Delete the node_modules folder. · Open the package.json · Search for "gulp": "gulpjs/gulp#4.0", and replace it ......
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found